innobackupex should skip GTID output is GTID_MODE is OFF

Bug #1391041 reported by Jervin R on 2014-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Sergei Glushchenko
2.1
Won't Fix
Undecided
Unassigned
2.2
Fix Released
Medium
Sergei Glushchenko
2.3
Fix Released
Medium
Sergei Glushchenko

Bug Description

Below are log outputs from different backups on the same server with GTID mode is OFF - the GTID part can cause confusion since its none incrementing.

innobackupex: MySQL binlog position: filename 'mysql-bin.000287', position 431329357, gtid_executed 72be0aa4-3988-11e4-bf5a-0cc47a08e7b0:1-213

innobackupex: MySQL binlog position: filename 'mysql-bin.000287', position 463378077, gtid_executed 72be0aa4-3988-11e4-bf5a-0cc47a08e7b0:1-213

Related branches

Able to reproduce the same. I would agree that if GTID_MODE=OFF then it should not covered while backup.

innobackupex: Backup created in directory '/home/nilnandan/backup/2014-11-13_13-46-00'
innobackupex: MySQL binlog position: filename 'mysql-bin.000003', position 338, GTID of the last change 'd05ede31-5361-11e4-a7e9-4ceb42171cea:1-6'
141113 13:46:28 innobackupex: Connection to database server closed
141113 13:46:28 innobackupex: completed OK!
nilnandan@Dell-XPS:~$

innobackupex: Backup created in directory '/home/nilnandan/backup/2014-11-13_13-47-32'
innobackupex: MySQL binlog position: filename 'mysql-bin.000003', position 637, GTID of the last change 'd05ede31-5361-11e4-a7e9-4ceb42171cea:1-6'
141113 13:48:00 innobackupex: Connection to database server closed
141113 13:48:00 innobackupex: completed OK!
nilnandan@Dell-XPS:~$

Changed in percona-xtrabackup:
status: New → Confirmed
Alexey Kopytov (akopytov) wrote :

It also makes sense to fix the opposite case: skip non-GTID coordinates when GTID mode is enabled. It is important for multi-threaded slaves, because GTID is the only reliable slave state source for MTS.

I had plans to implement that for the next release. Let's keep this report to fix both GTID and non-GTID cases.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-712

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers