Incremental backup fail with innodb_undo_tablespaces > 1

Bug #1363234 reported by Martin Arrieta on 2014-08-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
High
Sergei Glushchenko
2.1
Fix Released
High
Sergei Glushchenko
2.2
Fix Released
High
Sergei Glushchenko
2.3
Fix Released
High
Sergei Glushchenko

Bug Description

Package list:

percona-release-0.0-1.x86_64
Percona-Server-client-56-5.6.20-rel68.0.el6.x86_64
Percona-Server-server-56-5.6.20-rel68.0.el6.x86_64
Percona-Server-shared-56-5.6.20-rel68.0.el6.x86_64
percona-xtrabackup-2.2.3-4982.el6.x86_64
perl-DBD-MySQL-4.013-3.el6.x86_64

Incremental backups with innodb_undo_tablespaces > 1 it return an error when you apply the second incremental:

innodb_file_format_check=1
innodb_file_format_max=Barracuda
innodb_file_per_table=1
innodb_flush_log_at_trx_commit=2
innodb_flush_method=O_DIRECT

innodb_rollback_segments=128

140829 19:06:06 innobackupex: Starting ibbackup with command: xtrabackup --defaults-file="/root/backup/full/backup-my.cnf" --defaults-group="mysqld" --prepare --target-dir=/root/backup/full --apply-log-only --incremental-dir=/root/backup/inc2 --tmpdir=/tmp

xtrabackup version 2.2.3 based on MySQL server 5.6.17 Linux (x86_64) (revision id: )
incremental backup from 366196955 is enabled.
xtrabackup: cd to /root/backup/full
xtrabackup: This target seems to be already prepared.
xtrabackup: xtrabackup_logfile detected: size=2097152, start_lsn=(366527968)
xtrabackup: using the following InnoDB configuration for recovery:
xtrabackup: innodb_data_home_dir = ./
xtrabackup: innodb_data_file_path = ibdata1:100M:autoextend
xtrabackup: innodb_log_group_home_dir = /root/backup/inc2
xtrabackup: innodb_log_files_in_group = 1
xtrabackup: innodb_log_file_size = 2097152
InnoDB: Unable to open undo tablespace './undo001'.
xtrabackup: error: xb_data_files_init() failed with error code 11
innobackupex: Error:
innobackupex: ibbackup failed at /usr/bin/innobackupex line 2610.

I'm attaching the full log of the backup and the incremental process. After remove this option (innodb_undo_tablespaces) the backup finish without issues.

Regards,

Martin
@MartinArrietaC

Related branches

Martin Arrieta (martinarrieta) wrote :

Verified with Xtrabackup 2.2.3 on PS 5.6.20

140902 15:10:16 innobackupex: Starting ibbackup with command: xtrabackup --defaults-file="/home/nilnandan/backup/2014-09-02_15-02-37/backup-my.cnf" --defaults-group="mysqld" --prepare --target-dir=/home/nilnandan/backup/2014-09-02_15-02-37 --incremental-dir=/home/nilnandan/backup/2014-09-02_15-02-37/incremental/2014-09-02_15-09-54 --tmpdir=/tmp

xtrabackup version 2.2.3 based on MySQL server 5.6.17 Linux (x86_64) (revision id: )
incremental backup from 1482746 is enabled.
xtrabackup: cd to /home/nilnandan/backup/2014-09-02_15-02-37
xtrabackup: This target seems to be already prepared.
xtrabackup: xtrabackup_logfile detected: size=2097152, start_lsn=(1782305)
xtrabackup: using the following InnoDB configuration for recovery:
xtrabackup: innodb_data_home_dir = ./
xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
xtrabackup: innodb_log_group_home_dir = /home/nilnandan/backup/2014-09-02_15-02-37/incremental/2014-09-02_15-09-54
xtrabackup: innodb_log_files_in_group = 1
xtrabackup: innodb_log_file_size = 2097152
InnoDB: Unable to open undo tablespace './undo001'.
xtrabackup: error: xb_data_files_init() failed with error code 11
innobackupex: Error:
innobackupex: ibbackup failed at /usr/bin/innobackupex line 2610.
root@nilnandan-Dell-XPS:~#

Changed in percona-xtrabackup:
status: New → Confirmed

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-165

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers