innobackupex --help and --version doesn't work if source destination isn't specifed

Bug #1223716 reported by Hrvoje Matijakovic on 2013-09-11
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup
High
Alexey Kopytov
2.0
Undecided
Unassigned
2.1
High
Alexey Kopytov
2.2
High
Alexey Kopytov

Bug Description

innobackupex --help and innobackupex --version require destination dir to be specified in order to work correctly.

root@ps56:~# innobackupex --version
innobackupex: Error: You must specify the backup directory.
root@ps56:~# innobackupex --help
innobackupex: Error: You must specify the backup directory.
root@ps56:~# innobackupex --version /tmp/
InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
and Percona LLC and/or its affiliates 2009-2013. All Rights Reserved.

This software is published under
the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

xtrabackup was built from current 2.1 trunk

tags: added: low-hanging-fruit
Ville Skyttä (vskytta) wrote :

Personally I think the importance of this bug is higher than the current "Low" because there's no documentation or man pages included in percona-xtrabackup rpm packages; the only source of help included in it is --help ...

Alexey Kopytov (akopytov) wrote :

Ville,

I agree, it doesn't make sense for such a trivial bug to stay in the Low priority queue. Changing importance to High and targeting for 2.1.7.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers