xtrabackup does not recognize checkpoint #0 as a valid checkpoint on --prepare

Bug #1196475 reported by Alexey Kopytov on 2013-07-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Alexey Kopytov
2.0
Fix Released
Medium
Alexey Kopytov
2.1
Fix Released
Medium
Alexey Kopytov

Bug Description

xtrabackup_init_temp_log() fails with "xtrabackup: No valid checkpoint found." if the only checkpoint present xtrabackup_logfile has 0 as its number. That is, in case the server is started and has to create new log files (so it writes the first checkpoint #0 on startup to the log file header), and the backup is performed before the next (i.e. 2nd checkpoint).

This started occurring in regression tests quite frequently after the test suite was modified to reduce the time between the server starts up and a backup process is started.

The root cause is the following check in xtrabackup_init_temp_log() which assumes no checkpoint #0 can be found in xtrabackup_logfile:

 if (ut_dulint_cmp(max_no, ut_dulint_zero) == 0) {
  msg("xtrabackup: No valid checkpoint found.\n");
  goto error;
 }

Related branches

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-644

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers