The port lock mechanism in XB test suite does not work

Bug #1194813 reported by Alexey Kopytov on 2013-06-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Medium
Alexey Kopytov
2.0
Fix Released
Medium
Alexey Kopytov
2.1
Fix Released
Medium
Alexey Kopytov

Bug Description

The following code in the XB test suite which is supposed to lock ports atomically doesn't work as intended:

 if ! set -C > $lockfile
 then
     set +C
     # check if the process still exists
...

It should be (set -C; > $lockfile) to check and lock the file atomically.

Related branches

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-643

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers