innobackupex automatic version detection does not work for latest PS/MySQL 5.1 releases

Reported by Alexey Kopytov on 2013-05-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona XtraBackup
High
Alexey Kopytov
2.0
High
Alexey Kopytov
2.1
High
Alexey Kopytov

Bug Description

innobackupex relies on innodb_version for 5.1 to get the correct binary name. However as of 5.1.68 innodb_version was changed to be a synonym for server version variable. So innobackupex fails as follows when run against MySQL or Percona Server 5.1.68+:

innobackupex: Error: Unsupported server version: '5.1.68-debug-log' (InnoDB version: '5.1.68-14.0'). Please report a bug at https://bugs.launchpad.net/percona-xtrabackup

Alexey Kopytov (akopytov) wrote :

The workaround is to set the version explicitly with --ibbackup=xtrabackup

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers