Broken symlink to /usr/bin/innobackupex from innobackupex-1.5.1

Bug #1038198 reported by Sean Chighizola on 2012-08-17
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona XtraBackup moved to https://jira.percona.com/projects/PXB
Fix Released
Critical
Unassigned
2.0
Fix Released
Critical
Unassigned
2.1
Fix Released
Critical
Unassigned

Bug Description

The latest revision of xtrabackup 2.0.2 breaks the symlink for innobackupex-1.5.1. This is not reproduced in 2.0.1.

ls -lh /usr/bin/inno*
-rwxr-xr-x 1 root root 97K 2012-08-06 12:05 /usr/bin/innobackupex
lrwxrwxrwx 1 root root 13 2012-08-17 08:01 /usr/bin/innobackupex-1.5.1 -> /innobackupex
-rwxr-xr-x 1 root root 14K 2011-02-10 01:30 /usr/bin/innochecksum

Fix, symlink should remove preceeding /.

Related branches

Thanks for your report. Which of the binary packages do you use?

I'm seeing this too, installing on Ubuntu Lucid 64 from the Percona repo in version percona-xtrabackup_2.0.2-461.lucid_amd64.deb

Confirmed with percona-xtrabackup_2.0.2-461.lucid_amd64.deb.

Yup, we are using Lucid 10.4, percona-xtrabackup_2.0.2-461.lucid_amd64.deb

On Mon, Aug 20, 2012 at 2:36 AM, Laurynas Biveinis <
<email address hidden>> wrote:
Confirmed with percona-xtrabackup_2.0.2-461.lucid_amd64.deb.

** Changed in: percona-xtrabackup/2.0
       Status: Incomplete => Confirmed

** Changed in: percona-xtrabackup/2.0
     Assignee: (unassigned) => Ignacio Nin (ignacio-nin)

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1038198

Title:
  Broken symlink to /usr/bin/innobackupex from innobackupex-1.5.1

Status in Percona XtraBackup:
  New
Status in Percona XtraBackup 2.0 series:
  Confirmed

Bug description:
  The latest revision of xtrabackup 2.0.2 breaks the symlink for
  innobackupex-1.5.1. This is not reproduced in 2.0.1.

  ls -lh /usr/bin/inno*
  -rwxr-xr-x 1 root root 97K 2012-08-06 12:05 /usr/bin/innobackupex
  lrwxrwxrwx 1 root root 13 2012-08-17 08:01 /usr/bin/innobackupex-1.5.1
-> /innobackupex
  -rwxr-xr-x 1 root root 14K 2011-02-10 01:30 /usr/bin/innochecksum

  Fix, symlink should remove preceeding /.

To manage notifications about this bug go to:
https://bugs.launchpad.net/percona-xtrabackup/+bug/1038198/+subscriptions

Changed in percona-xtrabackup:
milestone: none → 2.1-initial
assignee: nobody → Ignacio Nin (ignacio-nin)
importance: Undecided → Critical
status: New → In Progress
Changed in percona-xtrabackup:
status: In Progress → Fix Committed

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXB-235

Changed in percona-xtrabackup:
assignee: Ignacio Nin (ignacio-nin) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers