pt-summary doesn't detect LSI RAID control

Reported by Dave Juntgen on 2012-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit
Medium
Brian Fraser

Bug Description

New LSI RAID SAS Control is not detected in pt-summary

[root@xxx /usr/local/bin]# lspci | grep "RAID bus*"
03:00.0 RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS 9260 (rev 05)

In parse_raid_controller_lspci() the follow needs to be added:

...

if grep -q "RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS" $file; then
      echo 'LSI Logic MegaRAID SAS'
elsif grep -q "RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS" $file; then
      echo 'LSI Logic MegaRAID SAS'

...

Baron Schwartz (baron-xaprb) wrote :

Does the tool work well after you make this patch, and can it get status and format it correctly?

In my own bubble - yes.

On Tue, Apr 17, 2012 at 3:25 PM, Baron Schwartz <email address hidden> wrote:
> Does the tool work well after you make this patch, and can it get status
> and format it correctly?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/977226
>
> Title:
>  pt-summary new LSI RAID control undetected.
>
> Status in Percona Toolkit:
>  New
>
> Bug description:
>  New LSI RAID SAS Control is not detected in pt-summary
>
>  [root@xxx /usr/local/bin]# lspci | grep "RAID bus*"
>  03:00.0 RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS 9260 (rev 05)
>
>  In parse_raid_controller_lspci() the follow needs to be added:
>
>  ...
>
>  if grep -q "RAID bus controller: LSI Logic / Symbios Logic MegaRAID SAS" $file; then
>        echo 'LSI Logic MegaRAID SAS'
>  elsif grep -q "RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS" $file; then
>        echo 'LSI Logic MegaRAID SAS'
>
>  ...
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/percona-toolkit/+bug/977226/+subscriptions

--
David W. Juntgen

Seems reasonable to just incorporate this fix, then, and assume nothing else changes.

tags: added: pt-summary wrong-output
summary: - pt-summary new LSI RAID control undetected.
+ pt-summary doesn't detect LSI RAID control
Changed in percona-toolkit:
status: New → Confirmed
Changed in percona-toolkit:
status: Confirmed → In Progress
importance: Undecided → Medium
assignee: nobody → Brian Fraser (fraserbn)
milestone: none → 2.1.3
Brian Fraser (fraserbn) on 2012-08-01
Changed in percona-toolkit:
status: In Progress → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers