Infinite loop in pt-query-digest if a report crashes

Bug #888114 reported by Daniel Nichter
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Fix Released
Medium
Daniel Nichter
2.0
Fix Released
Medium
Daniel Nichter
2.1
Fix Released
Medium
Daniel Nichter

Bug Description

If anything crashes in the iteration pipeline process, which is where QueryReportFormatter is called, then the terminator pipeline process isn't called, and since --continue-on-error is on by default, the pipeline restarts, re-crashes, restarts, etc. The result is infinite report output.

Related branches

Changed in percona-toolkit:
status: New → Confirmed
Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

Duplicate bug 997912

Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

The iteration pipeline process, which is critical, is now retried twice if it dies, regardless of --continue-on-error. Because this process is critical, I though it's worth retrying because it's possible that one bad query class could cause a report to fail, but everything else would work fine. In any case, 3 attempts it better than an infinite loop, or no retries.

Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-433

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers