pt-mysql-summary needs a secure password flag

Bug #886221 reported by Jay Janssen on 2011-11-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit
Wishlist
Frank Cizmich

Bug Description

pt-mysql-summary needs a way to pass the password without it going into command history or in the ps output.

You should be able to use -p for this and the mysql client tools will
just prompt you as usual. Can you check that?

Jay Janssen (jay-janssen) wrote :

Did that, problem is that it prompts for the password about a dozen times, and not just once :)

On Nov 4, 2011, at 1:37 PM, Baron Schwartz wrote:

> You should be able to use -p for this and the mysql client tools will
> just prompt you as usual. Can you check that?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/886221
>
> Title:
> pt-mysql-summary needs a secure password flag
>
> Status in Percona Toolkit:
> New
>
> Bug description:
> pt-mysql-summary needs a way to pass the password without it going
> into command history or in the ps output.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/percona-toolkit/+bug/886221/+subscriptions

Jay Janssen

Baron Schwartz (baron-xaprb) wrote :

I can't think of a reasonable way to avoid this. All of the things
I can think of will use something nasty like expect. I suggest creating
~/.my.cnf instead; this is what I always do. I think this should be a
WontFix, because there are alternative ways to do it, and making the
tool itself do the work will be a coding nightmare IMO.

Jay Janssen (jay-janssen) wrote :

Baron,
  I think I agree with you. I'm sure I had figured out the way to do this with Expect at one point at my last job, but I don't think it made it into anything I opened sourced.
  My only counter-argument is that software is supposed to hide ugly and/or repetitive tasks from the user. However, thinking back to the performance audit I did last week, putting my credentials into a .my.cnf would have sped me up a lot, so practicality wins.

On Nov 4, 2011, at 4:14 PM, Baron Schwartz wrote:

> I can't think of a reasonable way to avoid this. All of the things
> I can think of will use something nasty like expect. I suggest creating
> ~/.my.cnf instead; this is what I always do. I think this should be a
> WontFix, because there are alternative ways to do it, and making the
> tool itself do the work will be a coding nightmare IMO.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/886221
>
> Title:
> pt-mysql-summary needs a secure password flag
>
> Status in Percona Toolkit:
> New
>
> Bug description:
> pt-mysql-summary needs a way to pass the password without it going
> into command history or in the ps output.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/percona-toolkit/+bug/886221/+subscriptions

Jay Janssen

tags: added: pt-mysql-summary spam
Changed in percona-toolkit:
status: New → Confirmed
Brian Fraser (fraserbn) on 2012-08-27
Changed in percona-toolkit:
importance: Undecided → Wishlist
tags: added: i54678
Changed in percona-toolkit:
status: Confirmed → In Progress
assignee: nobody → Frank Cizmich (frank-cizmich)
milestone: none → 2.3.1
Frank Cizmich (frank-cizmich) wrote :

Just noticed this is a a duplicate of

https://bugs.launchpad.net/percona-toolkit/+bug/1455486

fix released for 2.2.15

Feel free to comment if you believe this is not the same issue or any other problems you see with the solution provided.

Changed in percona-toolkit:
milestone: 2.3.1 → none
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers