pt-query-digest shouldn't print "Error: none" for tcpdump

Reported by Daniel Nichter on 2011-08-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit
High
Daniel Nichter

Bug Description

Imported from http://code.google.com/p/maatkit/issues/detail?id=1024

When pt-query-digest --type tcpdump is used and a query has no errors, an "Error: none" line is printed. This don't conform to other attributes where if there's no value then no value is printed. The "none" value is a hack that we need to fix.

Changed in percona-toolkit:
status: New → Confirmed
tags: added: wrong-output
Changed in percona-toolkit:
milestone: none → 2.1.9
status: Confirmed → In Progress
importance: Wishlist → High
assignee: nobody → Daniel Nichter (daniel-nichter)
Daniel Nichter (daniel-nichter) wrote :

Being fixed as part of bug 1103045.

Daniel Nichter (daniel-nichter) wrote :

The root cause and fix for this is recognizing "optional attributes", attributes that sometimes are and sometimes are not present for an event. Right now, Error_no is the only such attrib, and _make_event() includes it blindly. So to fix this, _make_event() now only includes certain "optional attribs" if they're actually defined.

Changed in percona-toolkit:
status: In Progress → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers