Some tools don't have --help or --version

Reported by Baron Schwartz on 2011-08-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit
Low
Daniel Nichter

Bug Description

--version doesn't work, and it should. We probably need some common code library to implement this by pulling it out of the POD. Example:

[baron@ginger bin]$ ./pt-sift --version
[baron@ginger bin]$

Changed in percona-toolkit:
status: New → Confirmed
Changed in percona-toolkit:
importance: Undecided → Low
assignee: nobody → Daniel Nichter (daniel-nichter)
Changed in percona-toolkit:
assignee: Daniel Nichter (daniel-nichter) → nobody
tags: added: all-tools
Brian Fraser (fraserbn) on 2012-03-08
tags: added: pt-align pt-mext pt-mysql-summary pt-pmp pt-sift pt-summary
removed: all-tools
Brian Fraser (fraserbn) on 2012-08-16
tags: removed: pt-mysql-summary pt-summary
Changed in percona-toolkit:
milestone: none → 2.2.2
summary: - The formerly Aspersa tools need --version implemented
+ Some bash tools don't have --version
summary: - Some bash tools don't have --version
+ Some Bash tools don't have --version
Changed in percona-toolkit:
assignee: nobody → Daniel Nichter (daniel-nichter)
Changed in percona-toolkit:
status: Confirmed → In Progress
summary: - Some Bash tools don't have --version
+ Some tools don't have --help or --version
Daniel Nichter (daniel-nichter) wrote :

Had to add --relative to pt-mext and make its short form -r because apparently the parse_options lib doesn't like single-letter options. --relative (-r) is backwards-compatible and better anyway.

Changed in percona-toolkit:
status: In Progress → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints