rpm missing dependency on perl-TermReadKey for --ask-pass

Bug #1421025 reported by Daniel Black on 2015-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Fix Released
Medium
Tomislav Plavcic

Bug Description

Installing the rpm doesn't pull in the dependency on perl-TermReadKey

As such running the toolkit commands with --ask-pass trigger a fault due to a missing perl module.

version: 2.2.12

Tags: pkg Edit Tag help
Changed in percona-toolkit:
assignee: nobody → Tomislav Plavcic (tplavcic)
Changed in percona-toolkit:
status: New → Confirmed
tags: added: pkg
Changed in percona-toolkit:
milestone: none → 2.2.14
importance: Undecided → Medium
Tomislav Plavcic (tplavcic) wrote :

Confirmed and should be fixed for next release since it's an easy fix in rpm spec file.
Ubuntu seems unaffected since debian/control file includes the dependency for libterm-readkey-perl package.

TEST:
[vagrant@t-centos6-64 ~]$ pt-find --ask-pass --tablesize +5G
Enter password: Cannot read response; is Term::ReadKey installed? Can't locate Term/ReadKey.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/bin/pt-find line 1366.

INSTALL:
sudo yum install perl-TermReadKey

TEST AGAIN:
[vagrant@t-centos6-64 ~]$ pt-find --ask-pass --tablesize +5G
Enter password:
[vagrant@t-centos6-64 ~]$
Works...

Changed in percona-toolkit:
status: Confirmed → Won't Fix
status: Won't Fix → Fix Committed
status: Fix Committed → Confirmed
Changed in percona-toolkit:
status: Confirmed → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-674

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers