[DOC] pt-table-checksum --where has badly formatted example

Bug #1419098 reported by Michael Coburn on 2015-02-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Fix Released
Low
Frank Cizmich

Bug Description

[In:Percona Toolkit Documentation]

on http://www.percona.com/doc/percona-toolkit/2.2/pt-table-checksum.html#cmdoption-pt-table-checksum--where

it shows:

:program:`pt-table-checksum` --where "ts > CURRENT_DATE - INTERVAL 1 DAY"

It should probably show:

pt-table-checksum --where "ts > CURRENT_DATE - INTERVAL 1 DAY"

the back ticks and :program: pieces don't make sense when you want to understand the example.

Tags: doc Edit Tag help
Changed in percona-toolkit:
assignee: nobody → Frank Cizmich (frank-cizmich)
importance: Undecided → Low
milestone: none → 2.2.14
status: New → In Progress
Hrvoje Matijakovic (hrvojem) wrote :

I think this is caused by code in util/pod2rst-fixed line 78:

$para =~ s/([^\/])$tool/$1:program:`$tool`/g unless $in_code_block;

which doesn't correctly detect a code-block if it's inside the options.

Other tools are affected as well, check:
http://www.percona.com/doc/percona-toolkit/2.2/pt-heartbeat.html#cmdoption-pt-heartbeat--stop

inside the crontab:
0 * * * * :program:`pt-heartbeat` ...

Changed in percona-toolkit:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Frank Cizmich (frank-cizmich) wrote :

Thanks Hrvoje!

For the record: Fixed by adding a perl oneliner that cleans up the html's. It is placed inside the jenkins job that generates them.

Changed in percona-toolkit:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-821

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers