pt-online-schema-change requests password twice

Bug #1286250 reported by markus_albe on 2014-02-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit
Medium
Frank Cizmich

Bug Description

~/sandboxes/msb_5_5_32$ ./pt-online-schema-change --user root --ask-pass --alter="MODIFY COLUMN i VARCHAR(255)" D=test,t=x --dry-run
Enter MySQL password:
Enter MySQL password:
Operation, tries, wait:
  copy_rows, 10, 0.25
  create_triggers, 10, 1
  drop_triggers, 10, 1
  swap_tables, 10, 1

~/sandboxes/msb_5_5_32$ ./pt-online-schema-change --version
pt-online-schema-change 2.2.7

Near line 7937 we can see (thanks Ernie Souhrada)
my $cxn = $make_cxn->(dsn => $dsn);
my $aux_cxn = $make_cxn->(dsn => $dsn, prev_dsn => $dsn);

Guess it should ask for pass only once? We fixed with globals, but I presume that won't be accepted as patch.

Related branches

Agustín G (guriandoro) on 2014-02-28
tags: added: i39404
Jericho Rivera (jericho-rivera) wrote :

Confirmed on pt-osc version since 2.2.1 to 2.2.7, not seen on pt-osc versions 2.1.x or 2.0.x
root@ubuntu:/home/percona# pt-online-schema-change --user root --ask-pass --alter="MODIFY COLUMN i VARCHAR(255)" D=test,t=tbl_test --dry-run
Enter MySQL password:
Enter MySQL password:
Operation, tries, wait:
  copy_rows, 10, 0.25
  create_triggers, 10, 1
  drop_triggers, 10, 1
  swap_tables, 10, 1
  update_foreign_keys, 10, 1

Changed in percona-toolkit:
status: New → Confirmed
tags: added: pt-online-schema-change
Frank Cizmich (frank-cizmich) wrote :

Here's a patch for version 2.2.7

Changed in percona-toolkit:
status: Confirmed → In Progress
milestone: none → 2.2.8
milestone: 2.2.8 → none
assignee: nobody → Frank Cizmich (frank-cizmich)
milestone: none → 2.2.8
status: In Progress → Fix Committed
importance: Undecided → Medium
Changed in percona-toolkit:
status: Fix Committed → In Progress
Changed in percona-toolkit:
status: In Progress → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers