pt-table-checksum doesn't respect --chunk-size-limit

Reported by Marcelo Altmann on 2013-08-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit
Undecided
Unassigned

Bug Description

I'm invoking pt-table-checksum 2.2.4 as follow:

pt-table-checksum --recursion-method=hosts --set-vars innodb_lock_wait_timeout=50 --replicate dba_tools.rep_checksum --no-check-plan --chunk-size-limit=0

I'm getting an error in one single table:
08-20T06:09:14 Skipping table production.Products because on the master it would be checksummed in one chunk but on these replicas it has too many rows:
 170573 rows on slave1
 189670 rows on slave2
 154844 rows on slave3
 189998 rows on slave4
 189380 rows on slave5
 188190 rows on slave6
The current chunk size limit is 150403 rows (chunk size=150403 * chunk size limit=1).

If I run SELECT COUNT(*) FROM production.Products it returns the same result for master and all replicas.
As I'm invoking pt-table-checksum with --chunk-size-limit=0, why it's using chunk size limit=1 ? I expect it to disable the chunk size check.

All servers are running 5.0.96-enterprise-log MySQL Enterprise Server (Commercial)

Rob Wagner (rjwagner-dba) wrote :

I'm also seeing this issue on PT 2.1.5.

Kenny Gryp (gryp) wrote :

This was already reported in bug 938660. This at least is some documentation issue.

chunk-size-limit becomes 1 if you set it to 0.

tags: added: chunking pt-table-checksum
Daniel Nichter (daniel-nichter) wrote :

Yes, the docs are a little odd because they say 1 is the minimum value, but the next paragraph says "use zero to disable". I'll re-review.

tags: added: ambiguity
Changed in percona-toolkit:
status: New → Confirmed
summary: - pt-table-checksum not respecting chunk size limit
+ pt-table-checksum doesn't respect --chunk-size-limit
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers