pt-query-digest 2.2 prints too many string values

Reported by Daniel Nichter on 2013-03-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit
Medium
Brian Fraser

Bug Description

In pt-query-digest 2.2 we removed and automatically enabled the option that used to cut string value lines to 80 chars by default. Now 2.2 displays all string values for a given metric, however this has an unintended consequence:

# InnoDB trxID 7D8A9A2F (1/0%), 7D8A9A81 (1/0%), 7D8AD7BD (1/0%), 7D8AE696 (1/0%) ...

That line is _very_ long because there were a lot of unique InnoDB trxID values.

Brian Fraser (fraserbn) on 2013-04-02
Changed in percona-toolkit:
assignee: nobody → Brian Fraser (fraserbn)
Brian Fraser (fraserbn) on 2013-04-16
Changed in percona-toolkit:
status: Confirmed → Fix Committed
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers