pt-online-schema-change Option to remove old triggers

Bug #1158950 reported by Marc Castrovinci on 2013-03-22
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Confirmed
Undecided
Unassigned

Bug Description

I was running pt-online-schema-change and had to abort the process due to the server load. I did a ctrl-C.

root@HOSTNAME:~# pt-online-schema-change --execute --alter "modify column quantity decimal(10,2), modify column total decimal(10,2), modify column cost decimal(10,2), modify column card_quantity decimal(10,2), modify column card_total decimal(10,2)" D=xxxxxx,t=xxxxx --chunk-index PRIMARY --no-check-plan > xxxxx_out
# Exiting on SIGTERM.

When I went to run it again and got the following error

root@HOSTNAME:~# pt-online-schema-change --execute --alter "modify column quantity decimal(10,2), modify column total decimal(10,2), modify column cost decimal(10,2), modify column card_quantity decimal(10,2), modify column card_total decimal(10,2)" D=xxxxx,t=xxxxxxxxx--chunk-index PRIMARY --no-check-plan
The table `xxxxxxxx`.`xxxxxxxxxxxx` has triggers. This tool needs to create its own triggers, so the table cannot already have triggers.

Would it be possible in the future to have a flag to clean up the triggers from previous attempts?

Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

Yes, I think such an option would be useful, especially since we plan to introduce other things in pt-osc like --resume which will allow the tool to be stopped in more half-finished states.

Since this isn't a bug, I've created https://blueprints.launchpad.net/percona-toolkit/+spec/pt-osc-clean-up instead.

tags: added: pt-online-schema-change
Changed in percona-toolkit:
status: New → Invalid
R (rprots) on 2017-08-31
Changed in percona-toolkit:
status: Invalid → Confirmed
Revision history for this message
Carlos Salguero (carlos-salguero) wrote :

I would prefer to detect CTRL-C and do a proper clean up

Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-1092

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers