pt-table-checksum uninitialized value in numeric lt (<) at line 8611

Reported by Baron Schwartz on 2012-09-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit
Medium
Brian Fraser

Bug Description

I'm getting this error on a MyISAM partitioned table that has lots of rows. I'm not immediately sure of the cause, and it doesn't always seem to happen. My local copy has some modifications, so here is the code in question:

8610 @chunks = sort { $a <=> $b } @chunks;
8611 if ( $chunks[0] < $max_chunk ) {
8612 if ( $check_pr ) {
8613 $check_pr->update(sub { return $chunks[0]; });
8614 }
8615
8616 # We shouldn't wait long here because we already waited
8617 # for all slaves to catchup at least until --max-lag.
8618 $sleep_time += 0.25 if $sleep_time <= $o->get('max-lag');
8619 PTDEBUG && _d('Sleep', $sleep_time, 'waiting for chunks');
8620 sleep $sleep_time;
8621 }

I note that earlier in the same section of code, we protect against this by doing ($chunks[0] || 0), so we might need to do that again here.

tags: added: crash
Changed in percona-toolkit:
status: New → Triaged
Brian Fraser (fraserbn) on 2012-11-01
Changed in percona-toolkit:
status: Triaged → In Progress
assignee: nobody → Brian Fraser (fraserbn)
Brian Fraser (fraserbn) on 2012-11-09
Changed in percona-toolkit:
milestone: none → 2.1.7
Changed in percona-toolkit:
milestone: 2.1.7 → 2.1.8
Changed in percona-toolkit:
importance: Undecided → Medium
Brian Fraser (fraserbn) on 2012-11-29
Changed in percona-toolkit:
status: In Progress → Fix Committed
summary: - pt-table-checksum uninitialized value in numeric lt (<) at line 8611.
+ pt-table-checksum uninitialized value in numeric lt (<) at line 8611
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers