pt-sift disables echo on OS X if there is a single timestamp

Bug #1040813 reported by Fernando Ipar on 2012-08-23
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit

Bug Description

On a system with this info:

telecaster:pt-stalk-samples fernandoipar$ uname -a
Darwin telecaster.local 11.4.0 Darwin Kernel Version 11.4.0: Mon Apr 9 19:32:15 PDT 2012; root:xnu-1699.26.8~1/RELEASE_X86_64 x86_64
telecaster:pt-stalk-samples fernandoipar$ bash --version
GNU bash, version 3.2.48(1)-release (x86_64-apple-darwin11)
Copyright (C) 2007 Free Software Foundation, Inc.

If I run pt-sift (as obtained just now from with only one timestamp in the captures directory, echo is disabled on the session. Executing the 'reset' command on the shell solves the problem.

If I run the script with two or more captures, I don't have this problem. I have been able to reproduce this with multiple captures but just in case (as I couldn't find one in the tests directory) I will be attaching a sample capture that can be used to reproduce this problem on a similar system.

I haven't tested this on other platforms yet.

Fernando Ipar (fipar) wrote :
tags: added: mac pt-sift wrong-output
Changed in percona-toolkit:
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers