pt-online-schema-change --quiet doesn't disable --progress

Bug #1039541 reported by Baron Schwartz
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Fix Released
Low
Daniel Nichter

Bug Description

Unless I'm reading the code wrong, progress reports will happen even when --quiet is specified, which is bad for cron jobs.

I'll attach a patch against 2.1.3.

Related branches

Revision history for this message
Baron Schwartz (baron-xaprb) wrote :
Revision history for this message
Brian Fraser (fraserbn) wrote :

Odd. I reached the same conclussion as you, but even without the patch, looks like progress reports aren't printed if --quiet is specified?

Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

Chances are this affects all the tools I just tagged. I don't ever recall conditionalizing --progress on --quiet.

tags: added: pt-archiver pt-index-usage pt-online-schema-change pt-trend wrong-behavior
Changed in percona-toolkit:
status: New → Confirmed
tags: added: quiet
removed: wrong-behavior
Changed in percona-toolkit:
milestone: none → 2.1.6
importance: Undecided → Low
Changed in percona-toolkit:
assignee: nobody → Daniel Nichter (daniel-nichter)
Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

This isn't a bug in pt-table-checksum because in --quiet: "(disables L<"--progress">)" which does disable --progress.

Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

Only pt-osc had this problem.

summary: - pt-table-checksum --quiet doesn't disable --progress
+ pt-online-schema-change --quiet doesn't disable --progress
tags: removed: pt-archiver pt-index-usage pt-table-checksum pt-trend
Changed in percona-toolkit:
status: Confirmed → Fix Committed
Brian Fraser (fraserbn)
Changed in percona-toolkit:
status: Fix Committed → Fix Released
Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-783

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers