pt-mysql-summary doesn't handle renamed variables in Percona Server 5.5

Reported by Baron Schwartz on 2012-06-20
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit
Medium
Brian Fraser

Bug Description

The “Percona Server features” section in pt-mysql-summary doesn’t recognize renamed variables in Percona Server 5.5.

# Key Percona Server features ################################
      Table & Index Stats | Not Supported
     Multiple I/O Threads | Enabled
     Corruption Resilient | Not Supported
      Durable Replication | Not Supported
     Import InnoDB Tables | Not Supported
     Fast Server Restarts | Not Supported
         Enhanced Logging | Not Supported
     Replica Perf Logging | Disabled
      Response Time Hist. | Not Supported
          Smooth Flushing | Not Supported
      HandlerSocket NoSQL | Not Supported
           Fast Hash UDFs | Unknown
# Plugins ####################################################
       InnoDB compression | ACTIVE

This is probably because of renamed variables. The last line in that sample also needs to be investigated, because apparently the server from which this sample was taken isn't even using the Barracuda file format.

tags: added: percona-server
Brian Fraser (fraserbn) on 2012-11-02
Changed in percona-toolkit:
assignee: nobody → Brian Fraser (fraserbn)
Brian Fraser (fraserbn) wrote :

The linked branch fixes the features part (Baron's analysis was correct -- the renamed variables weren't beign taken into account).
I don't think that the plugins bit is wrong -- 'ACTIVE' comes from MySQL itself, by doing SHOW PLUGINS and then awk'ing the line with INNODB_CMP.

Changed in percona-toolkit:
status: Confirmed → In Progress
Brian Fraser (fraserbn) on 2012-11-09
Changed in percona-toolkit:
milestone: none → 2.1.7
Changed in percona-toolkit:
milestone: 2.1.7 → 2.1.8
Brian Fraser (fraserbn) on 2012-12-06
Changed in percona-toolkit:
status: In Progress → Fix Committed
summary: - pt-mysql-summary not Percona Server 5.5-ready
+ pt-mysql-summary doesn't handle renamed variables in Percona Server 5.5
Changed in percona-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers