pt-table-sync --ignore-* options don't work with --replicate

Bug #1002365 reported by Daniel Nichter
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Toolkit moved to https://jira.percona.com/projects/PT
Fix Released
High
Daniel Nichter
2.0
Fix Released
High
Daniel Nichter
2.1
Fix Released
High
Daniel Nichter

Bug Description

There are tests for this (schema filters with --replicate), but there's no specific test for --replicate and --ignore-tables, so there could very well be a bug lurking here.

Related branches

tags: added: percona-21967
summary: - Some schema filters don't work with pt-table-sync --replicate
+ pt-table-sync --ignore-* options don't work with --replicate
Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

I have reproduced this bug. Turns out, none of the --ignore-* options are applied to --replicate which uses filter_diffs() internally. It should use SchemaIterator::table_is_allowed() and friends instead.

Revision history for this message
Daniel Nichter (daniel-nichter) wrote :

FIxing this in 2.0 required more extensive work. 2.0 was using an old SchemaIterator, but now it's using the latest from 2.1.

Revision history for this message
Baron Schwartz (baron-xaprb) wrote :

If we find in future cases that a bug is pretty intrusive to fix in the non-current series I'd advocate not fixing it; only fix "easy wins" in the old version. In reality very few people should be using the old versions; it isn't like RHEL where people want to stay on a single version for 8 years.

Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PT-314

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers