Sort aborted with no proper information

Bug #1203050 reported by [Plus] on 2013-07-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Low
Unassigned
5.1
Won't Fix
Low
Unassigned
5.5
Fix Released
Low
Unassigned
5.6
Fix Released
Low
Unassigned

Bug Description

Server version : 5.5.31-30.3 Percona Server (GPL), Release 30.3
Linux db-56 3.2.0-41-generic #66-Ubuntu SMP Thu Apr 25 03:27:11 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Hi,

The description message for the "Sort Aborted" error indicates "Server shutdown in progress" but the server is fully operational.
Here is an extract of my error log :

130719 9:57:02 [ERROR] /usr/sbin/mysqld: Sort aborted: Server shutdown in progress
130719 9:57:02 [Warning] Sort aborted, host: XX.XX.XX.XX, user: user1, thread: 6510357, query: SELECT....

Related parameters :
log_warnings = 2
sort_buffer_size = 2M

Regs
Cédric

Related branches

Do you know the exact reason for the "Sort Aborted" in this case? I mean, had you used explicit KILL QUERY or maybe sent some signal to mysqld process?

Changed in percona-server:
status: New → Incomplete

Yes, the query was killed.
There aren't any more information in the errorlog other than those already listed

Changed in percona-server:
status: Incomplete → New

OK, I was able to reproduce this. Last messages from the error log in my case:

...
2013-07-21 11:10:56 1468 [Note] /usr/sbin/mysqld: ready for connections.
Version: '5.6.12-rc60.4' socket: '/var/run/mysqld/mysqld.sock' port: 3306 Percona Server (GPL), Release 60.4
2013-07-22 16:02:56 1468 [ERROR] /usr/sbin/mysqld: Sort aborted: Query execution was interrupted
2013-07-22 16:05:15 1468 [ERROR] /usr/sbin/mysqld: Sort aborted: Query execution was interrupted
2013-07-22 16:05:15 1468 [Warning] Sort aborted, host: localhost, user: root, thread: 45, query: create temporary table tt select t1.user from mysql.user t1, mysql.user t2, mysql.user t3, mysql.user t4, mysql.user t5, mysql.user t6, mysql.user t7, mysql.user t8, mysql.user t9 order by 1 desc
2013-07-22 16:06:31 1468 [ERROR] /usr/sbin/mysqld: Sort aborted: Query execution was interrupted
2013-07-22 16:06:31 1468 [Warning] Sort aborted, host: localhost, user: root, thread: 46, query: create temporary table tt select t1.user from mysql.user t1, mysql.user t2, mysql.user t3, mysql.user t4, mysql.user t5, mysql.user t6, mysql.user t7, mysql.user t8, mysql.user t9 order by 1 desc
2013-07-22 16:07:24 1468 [ERROR] /usr/sbin/mysqld: Sort aborted: Server shutdown in progress
2013-07-22 16:07:24 1468 [Warning] Sort aborted, host: localhost, user: root, thread: 47, query: create temporary table tt select t1.user from mysql.user t1, mysql.user t2, mysql.user t3, mysql.user t4, mysql.user t5, mysql.user t6, mysql.user t7, mysql.user t8, mysql.user t9 order by 1 desc

See last message, it says about shutdown in progress. It happens when I run KILL <session_id> instead of KILL QUERY <session id>.

This is a actually a duplicate of upstream bug I've verified years ago: http://bugs.mysql.com/bug.php?id=18256.

tags: added: upstream

Upstream fix in 5.5.35 and 5.6.15.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2035

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.