percona-server doesn't provide mysql-common

Bug #877018 reported by FreeK on 2011-10-18
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Percona Server
High
Ignacio Nin

Bug Description

When installing any package (eg zend-server-ce incl. PHP 5.3), dependency check failes:

root@sun:~# apt-get install php-5.3-common-extensions-zend-server php-5.3-mysqli-zend-server libmysqlclient15off
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libmysqlclient15off : Depends: mysql-common (>= 5.0.51a-24+lenny5)
E: Broken packages

Installing mysql-common will remove percona.

Packages installed (mysql and percona):
ii libmysqlclient16 5.1.59-rel13.0-325.squeeze Percona Server database client library
ii libmysqlclient18 5.5.16-rel22.0-189.squeeze Percona Server database client library
ii percona-server-common-5.5 5.5.16-rel22.0-189.squeeze Percona Server database common files (e.g. /etc/mysql/my.cnf)
ii percona-server-client-5.5 5.5.16-rel22.0-189.squeeze Percona Server database client binaries
ii percona-server-server-5.5 5.5.16-rel22.0-189.squeeze Percona Server database server binaries

System:
root@sun:~# cat /etc/debian_version
6.0.3
root@sun:~# uname -a
Linux sun 2.6.32-5-amd64 #1 SMP Mon Oct 3 03:59:20 UTC 2011 x86_64 GNU/Linux

NO APACHE, NO PHP installed!

Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
Stewart Smith (stewart) on 2011-10-21
tags: added: pkg
FreeK (stephan-breitrainer) wrote :

Any news or any other informations needed?

Stewart Smith (stewart) on 2012-02-07
Changed in percona-server:
importance: Undecided → High
Bart Verwilst (verwilst) wrote :

I have the same issue on Lucid:

# apt-get install php5-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-mysql: Depends: libmysqlclient16 (>= 5.1.21-1) but it is not going to be installed
E: Broken packages

# apt-get install libmysqlclient16
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libmysqlclient16: Depends: mysql-common (>= 5.1.61-0ubuntu0.10.04.1)
E: Broken packages

# dpkg -l | grep percona-server
ii percona-server-client-5.5 5.5.20-rel24.1-217.lucid Percona Server database client binaries
ii percona-server-common-5.5 5.5.20-rel24.1-217.lucid Percona Server database common files (e.g. /etc/mysql/m
ii percona-server-server-5.5 5.5.20-rel24.1-217.lucid Percona Server database server binaries

Bart Verwilst (verwilst) wrote :
Download full text (3.7 KiB)

For now i fixed it like this, but it's very dirty..:

# aptitude install libmysqlclient16
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  percona-server-common-5.5
The following NEW packages will be installed:
  libmysqlclient16 mysql-common{a}
0 packages upgraded, 2 newly installed, 0 to remove and 74 not upgraded.
Need to get 2,027kB of archives. After unpacking 4,624kB will be used.
The following packages have unmet dependencies:
  percona-server-common-5.5: Conflicts: mysql-common but 5.1.61-0ubuntu0.10.04.1 is to be installed.
                             Conflicts: mysql-common-4.1 which is a virtual package.
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-client-5.5
percona-server-common-5.5
percona-server-server-5.5
xtrabackup

Score is -26

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-client-5.5
percona-server-common-5.5
percona-server-server-5.5

Install the following packages:
mysql-cluster-client-5.1 [7.0.9-1ubuntu7 (lucid)]

Score is -106

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-client-5.5
percona-server-common-5.5
percona-server-server-5.5

Install the following packages:
libdbd-mysql-perl [4.012-1ubuntu1 (lucid)]
mysql-client-5.1 [5.1.61-0ubuntu0.10.04.1 (lucid-updates, lucid-security)]
mysql-client-core-5.1 [5.1.61-0ubuntu0.10.04.1 (lucid-updates, lucid-security)]

Score is -124

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-client-5.5
percona-server-common-5.5
percona-server-server-5.5

Install the following packages:
libdbd-mysql-perl [4.012-1ubuntu1 (lucid)]
mysql-client-5.1 [5.1.41-3ubuntu12 (lucid)]
mysql-client-core-5.1 [5.1.61-0ubuntu0.10.04.1 (lucid-updates, lucid-security)]

Score is -144

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Remove the following packages:
percona-server-client-5.5
percona-server-common-5.5
percona-server-server-5.5

Install the following packages:
libdbd-mysql-perl [4.012-1ubuntu1 (lucid)]
mysql-client-5.1 [5.1.41-3ubuntu12 (lucid)]
mysql-client-core-5.1 [5.1.41-3ubuntu12 (lucid)]

Score is -164

Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

Install the following packages:
libmysqlclient16 [5.1.59-rel13.0-325.lucid (lucid)]

Keep the following packages at their current version:
mysql-common [Not Installed]

Score is -9911

Accept this solution? [Y/n/q/?] y
The following NEW packages will be installed:
  libmysqlclient16
0 packages upgraded, 1 newly installed, 0 to remove and 74 not upgraded.
Need to get 3,670kB of archives. After unpacking 10.2MB will be used.
Do you want to continue? [Y/n/?] y
Writing extended state information... Done
Get:1 http://apt/ lucid/main libmysqlclient16 5.1.59-rel13.0-325.lucid [3,670kB]
Fe...

Read more...

Ignacio Nin (ignacio-nin) wrote :

Hello,

I cannot reproduce the problem in lucid or precise with the following repositories:

deb http://repo.percona.com/apt lucid main
deb-src http://repo.percona.com/apt lucid main
deb http://repos.zend.com/zend-server/deb server non-free

The line pasted (apt-get install php-5.3-common-extensions-zend-server php-5.3-mysqli-zend-server libmysqlclient15off) installs fine on both ubuntu servers.

Please follow up with exact system information, and repositories installed.

Thanks!

N.

Ignacio Nin (ignacio-nin) wrote :

[Regarding last post, squeeze (debian6) also tested with the appropriate repositories]

Changed in percona-server:
status: New → Incomplete
Radu Epure (radurazvan-epure) wrote :

I confirm the bug report, however i only tested with percona-server-server-5.1 on Debian 6 Squeeze.

Steps to reproduce:
1. Download and install debian 6.

2. Add in /etc/apt/sources.list the following lines:
deb http://repo.percona.com/apt squeeze main
deb http://repos.zend.com/zend-server/deb server non-free

3. Install percona-server-server-5.1

4. Try and install zend-server-php-5.3

php-5.3-mysql-zend-server package depends of libmysqlclient15off which in turn depends on mysql-common which is not provided by percona-server-server-5.1 package. As a result the solution provided by apt is to remove percona and install mysql.

John Ferlito (johnf-inodes) wrote :
Download full text (4.0 KiB)

I've tested replicating this on a brand new EC2 VM running precise 12.04.1, steps were as follows

sudo -i
echo "deb http://repo.percona.com/apt precise main" >> /etc/apt/sources.list
echo "deb http://repos.zend.com/zend-server/deb server non-free" >> /etc/apt/sources.list
apt-get update
apt-get install zend-server-php-5.3 # Works fine
apt-get install percona-server-server
root@ip-10-178-67-248:~# apt-get install percona-server-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 percona-server-server : Depends: percona-server-server-5.5 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

You can try and force it but then it tries to uninstall zend

 apt-get install percona-server-server percona-server-server-5.5 percona-server-client-5.5 percona-server-common-5.5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  php-5.3-soap-zend-server php-5.3-curl-zend-server php-5.3-xsl-zend-server libapache2-mod-php-5.3-zend-server lighttpd-zend-server php-5.3-posix-zend-server
  php-5.3-debugger-zend-server libicu36 libpng3 sqlite php-5.3-cm-utils-pe-zend-server php-5.3-monitor-ui-zend-server php-5.3-bin-zend-server php-5.3-sockets-zend-server
  php-5.3-ftp-zend-server php-5.3-ctype-zend-server zend-base php-5.3-page-cache-zend-server php-5.3-pdo-oci-zend-server libcap2 php-5.3-gd-zend-server php-5.3-zem-zend-server
  php-5.3-sqlite-zend-server cli-tools-zend-server libapr1 php-5.3-sc-zend-server zend-server-doc php-5.3-zip-zend-server php-5.3-zend-extensions php-5.3-ldap-zend-server
  php-5.3-optimizer-plus-zend-server libsqlite0 deployment-daemon-zend-server php-5.3-monitor-zend-server php-5.3-fcgi-zend-server php-5.3-json-zend-server
  php-5.3-calendar-zend-server libaprutil1-ldap apache2-mpm-prefork php-5.3-pdo-pgsql-zend-server php-5.3-mcrypt-zend-server apache2-utils php-5.3-phar-zend-server
  php-5.3-imap-zend-server libmcrypt4 php-5.3-oci8-zend-server apache2.2-common libframework1-zend-server php-5.3-zendutils-zend-server libaprutil1-dbd-sqlite3 zend-server-framework
  php-5.3-zds-zend-server apache2.2-bin jobqueue-zend-server deployment-extension-zend-server ssl-cert php-5.3-bcmath-zend-server php-5.3-tokenizer-zend-server
  php-5.3-fileinfo-zend-server jq-daemon-zend-server php-5.3-mbstring-zend-server php-5.3-tidy-zend-server php-5.3-gettext-zend-server liboci-us-locales-zend zend-server-framework2
  libssl0.9.8 php-5.3-exif-zend-server libpq5 php-5.3-jq-zend-server php-5.3-dev-zend-server php-5.3-code-tracing-zend-server php-5.3-session-clustering-zend-server
  php-5.3-bz2-zend-server php-5.3-pgsql-zend-server php-5.3-intl-zend-server libaprutil1 php-5.3-data-cache-zend-server sc-daem...

Read more...

Changed in percona-server:
status: Incomplete → New
Jaime Sicam (jssicam) on 2012-10-02
tags: added: i23743
Changed in percona-server:
status: New → Fix Released
Changed in percona-server:
status: Fix Released → In Progress
Ignacio Nin (ignacio-nin) wrote :

Zend requires on libmysqlclient15off, which we no longer provided in our "newer" repos (squeeze, precise, etc).

The official precise repositories offers a solution brought back from lenny:

# apt-cache show libmysqlclient15off
Package: libmysqlclient15off
Source: mysql-dfsg-5.0
Version: 5.0.51a-24+lenny5
(snip)
Depends: mysql-common (>= 5.0.51a-24+lenny5), libc6 (>= 2.7-1), zlib1g (>= 1:1.1.4)

We do offer a libmysqlclient15off in our lenny repo which doesn't depend on a versioned mysql-common:
Package: libmysqlclient15off
Source: percona-sql-dfsg-5.0
Version: 5.0.92-b23.87.lenny
(snip)
Depends: mysql-common, libc6 (>= 2.7-1), zlib1g (>= 1:1.1.4)

We've now added our version of libmysqlclient15off to the other versions repository, so the commands should be working after updating your local cache of our repos:

# apt-get install percona-server-server-5.1 zend-server-php-5.3
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
apache2-mpm-prefork apache2-utils apache2.2-common....

Changed in percona-server:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers