Regression in log_slow_admin_statements handling in 5.1

Bug #860416 reported by Alexey Kopytov on 2011-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Undecided
Oleg Tsarev

Bug Description

https://code.launchpad.net/~tsarev/percona-server/test51_691404/+merge/74982 has introduced a regression in 5.1. Before that change log_slow_admin_statements would not accept any string values except 'true' or 'false'. Now, the option accepts any string values. What's even worse, setting it to 'true' will not really enable the option.

Before the change:

1. log_slow_admin_statements=true (in my.cnf or command line) leads to a normal startup without warnings. "select @@log_slow_admin_statements;" returns "1";

2. log_slow_admin_statements=foo (in my.cnf or command line) leads to a warning during startup:

[Warning] ./mysqld: ignoring option '--log-slow-admin-statements' due to invalid value 'foo'

"select @@log_slow_admin_statements;" returns 0;

After the change:

1. log_slow_admin_statements=true (in my.cnf or command line) leads to a normal startup without warnings. "select @@log_slow_admin_statements;" returns "0";

2. log_slow_admin_statements=foo (in my.cnf or command line) leads to a normal startup without warnings;
"select @@log_slow_admin_statements;" returns 0;

Related branches

lp:~tsarev/percona-server/5.1_fix_bug_860416
Merged into lp:percona-server/5.1 at revision 322
Laurynas Biveinis: Approve on 2011-10-08
lp:~tsarev/percona-server/5.1.59-porting
Merged into lp:percona-server/5.1 at revision 323
Stewart Smith (community): Approve on 2011-10-09
Changed in percona-server:
milestone: none → 5.1.59-13.0
assignee: nobody → Oleg Tsarev (tsarev)
status: New → Confirmed
Oleg Tsarev (tsarev) on 2011-09-27
Changed in percona-server:
status: Confirmed → In Progress
Oleg Tsarev (tsarev) on 2011-09-28
Changed in percona-server:
status: In Progress → Fix Committed
Oleg Tsarev (tsarev) on 2011-10-08
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers