Percona Server with XtraDB

mtr internal check of INNODB_FILE_FORMAT_CHECK fails in debug builds

Reported by Stewart Smith on 2011-06-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Undecided
Unassigned
5.1
Critical
Alexey Kopytov

Bug Description

http://ec2-75-101-139-139.compute-1.amazonaws.com/job/percona-server-5.1-trunk/BUILD_TYPE=debug-no-Werror,Host=ubuntu-lucid-64bit/14/console
(all debug builds)

First occurs:
rpl.rpl_binlog_errors 'mix' w1 [ pass ] 86537

MTR's internal check of the test case 'rpl.rpl_binlog_errors' failed.
This means that the test case does not preserve the state that existed
before the test case was executed. Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Logging to '/jenkins/workspace/percona-server-5.1-trunk/BUILD_TYPE/debug-no-Werror/Host/ubuntu-lucid-64bit/Percona-Server-5.1.57/mysql-test/var/1/tmp/check-mysqld_1.log'.
mysqltest: Results saved in '/jenkins/workspace/percona-server-5.1-trunk/BUILD_TYPE/debug-no-Werror/Host/ubuntu-lucid-64bit/Percona-Server-5.1.57/mysql-test/var/1/tmp/check-mysqld_1.result'.
mysqltest: Connecting to server localhost:13000 (socket /tmp/WCjGnx4Rbk/1/mysqld.1.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /jenkins/workspace/percona-server-5.1-trunk/BUILD_TYPE/debug-no-Werror/Host/ubuntu-lucid-64bit/Percona-Server-5.1.57/mysql-test/var/1/tmp/check-mysqld_1.result 2011-06-08 19:10:46.000000000 +0300
+++ /jenkins/workspace/percona-server-5.1-trunk/BUILD_TYPE/debug-no-Werror/Host/ubuntu-lucid-64bit/Percona-Server-5.1.57/mysql-test/var/1/tmp/check-mysqld_1.reject 2011-06-08 19:12:14.000000000 +0300
@@ -101,7 +101,7 @@
 INNODB_FAST_RECOVERY OFF
 INNODB_FAST_SHUTDOWN 1
 INNODB_FILE_FORMAT Antelope
-INNODB_FILE_FORMAT_CHECK Antelope
+INNODB_FILE_FORMAT_CHECK Barracuda
 INNODB_FILE_PER_TABLE OFF
 INNODB_FLUSH_LOG_AT_TRX_COMMIT 1
 INNODB_FLUSH_LOG_AT_TRX_COMMIT_SESSION 3

mysqltest: Result content mismatch

Stewart Smith (stewart) wrote :

Also observed for a valgrind build:
http://jenkins.percona.com/job/percona-server-5.1-valgrind/BUILD_TYPE=valgrind,Host=ubuntu-natty-64bit/1/console

innodb_plugin.innodb_bug60049 w4 [ pass ] 2471

MTR's internal check of the test case 'innodb_plugin.innodb_bug60049' failed.
This means that the test case does not preserve the state that existed
before the test case was executed. Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Logging to '/jenkins/workspace/percona-server-5.1-valgrind/BUILD_TYPE/valgrind/Host/ubuntu-natty-64bit/Percona-Server-5.1.57/mysql-test/var/4/tmp/check-mysqld_1.log'.
mysqltest: Results saved in '/jenkins/workspace/percona-server-5.1-valgrind/BUILD_TYPE/valgrind/Host/ubuntu-natty-64bit/Percona-Server-5.1.57/mysql-test/var/4/tmp/check-mysqld_1.result'.
mysqltest: Connecting to server localhost:13030 (socket /tmp/gSnVireLp6/4/mysqld.1.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /jenkins/workspace/percona-server-5.1-valgrind/BUILD_TYPE/valgrind/Host/ubuntu-natty-64bit/Percona-Server-5.1.57/mysql-test/var/4/tmp/check-mysqld_1.result 2011-06-09 04:07:14.846099000 +0300
+++ /jenkins/workspace/percona-server-5.1-valgrind/BUILD_TYPE/valgrind/Host/ubuntu-natty-64bit/Percona-Server-5.1.57/mysql-test/var/4/tmp/check-mysqld_1.reject 2011-06-09 04:07:17.556099003 +0300
@@ -99,7 +99,7 @@
 INNODB_FAST_RECOVERY OFF
 INNODB_FAST_SHUTDOWN 0
 INNODB_FILE_FORMAT Antelope
-INNODB_FILE_FORMAT_CHECK Antelope
+INNODB_FILE_FORMAT_CHECK Barracuda
 INNODB_FILE_PER_TABLE OFF
 INNODB_FLUSH_LOG_AT_TRX_COMMIT 1
 INNODB_FLUSH_LOG_AT_TRX_COMMIT_SESSION 3

mysqltest: Result content mismatch

not ok

Changed in percona-server:
status: New → Fix Released
Oleg Tsarev (tsarev) wrote :

Again actual after fix bug #838725

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers