Percona Server with XtraDB

5.5.11 lenny libmysqlclient18 fails to install

Reported by Valentine Gostev on 2011-04-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona Server
Critical
Ignacio Nin

Bug Description

test-lenny-32-t507:~/distr# dpkg -i libmysqlclient18_5.5.11-rel20.2-105.lenny_i386.deb
Selecting previously deselected package libmysqlclient18.
(Reading database ... 22523 files and directories currently installed.)
Unpacking libmysqlclient18 (from libmysqlclient18_5.5.11-rel20.2-105.lenny_i386.deb) ...
dpkg: dependency problems prevent configuration of libmysqlclient18:
 libmysqlclient18 depends on dpkg (>= 1.15.4) | install-info; however:
  Version of dpkg on system is 1.14.31.
  Package install-info is not installed.
dpkg: error processing libmysqlclient18 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libmysqlclient18
test-lenny-32-t507:~/distr#

Valentine Gostev (longbow) wrote :

dpkg 1.14.31 is shipped with lenny, libmysqlclient18 requires dpkg 1.15.4

Changed in percona-projects-qa:
assignee: nobody → Ignacio Nin (ignacio-nin)
summary: - 5.5.11 lenny x86 libmysqlclient fails to install
+ 5.5.11 lenny libmysqlclient18 fails to install
Changed in percona-projects-qa:
milestone: none → 5.5.11
Ignacio Nin (ignacio-nin) wrote :

The dependency is on either dpkg >= 1.15.4 or install-info, issuing apt-get -f install will fix it by installing install-info.

Changed in percona-projects-qa:
status: New → Invalid
Bassam Tabbara (bassamtabbara) wrote :

install-info does not seem to be available on lenny:

http://packages.debian.org/sid/install-info

its only available on sid, squeeze and lenny-backports.

We are unable to install percona5.5 on lenny.

Changed in percona-projects-qa:
status: Invalid → Confirmed
Valentine Gostev (longbow) wrote :

Can not reproduce with 5.5.12-20.3. Marking as Resolved.

Changed in percona-projects-qa:
status: Confirmed → Fix Released
Mark Hughes (mark-cyki) wrote :

Hi,

I'm seeing this problem with the latest version:

XXX~/percona# dpkg -i libmysqlclient18_5.5.12-rel20.3-118.lenny_amd64.deb
(Reading database ... 37715 files and directories currently installed.)
Preparing to replace libmysqlclient18 5.5.12-rel20.3-118.lenny (using libmysqlclient18_5.5.12-rel20.3-118.lenny_amd64.deb) ...
Unpacking replacement libmysqlclient18 ...
dpkg: dependency problems prevent configuration of libmysqlclient18:
 libmysqlclient18 depends on dpkg (>= 1.15.4) | install-info; however:
  Version of dpkg on system is 1.14.31.
  Package install-info is not installed.
dpkg: error processing libmysqlclient18 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libmysqlclient18

Thanks,
Mark.

Changed in percona-projects-qa:
status: Fix Released → New
Mateusz (mateusz2) wrote :

I also confirm this problem. Debian Lenny 32-bit:

apt-get -f install libmysqlclient18
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
  libmysqlclient18: Depends: dpkg (>= 1.15.4) but 1.14.31 is to be installed or
                             install-info but it is not installable
E: Broken packages

Stewart Smith (stewart) on 2011-06-20
affects: percona-projects-qa → percona-server
Changed in percona-server:
milestone: 5.5.11 → none
importance: Undecided → Critical
status: New → Triaged
milestone: none → 5.5.13-20.4
Ignacio Nin (ignacio-nin) wrote :

Solved in 5.5.13-20.4 for lenny. Compiled for lenny avoiding the install-info or dpkg 1.15 dependency.

libmysqlclient18 installs with dpkg 1.14.31 and no install-info installed.

Changed in percona-server:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers