Intermittent innodb.innodb_bug60049 test failures

Bug #756387 reported by Alexey Kopytov on 2011-04-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
MariaDB
Incomplete
Undecided
Unassigned
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.1
Invalid
Low
Unassigned
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Invalid
Low
Unassigned
5.7
Invalid
Low
Unassigned

Bug Description

5.5.11 contains a new test, innodb.innodb_bug60049. The test passes in the upstream server, but fails in lp:percona-server/5.5.11 as follows on both Linux and Mac OS X:

CURRENT_TEST: innodb.innodb_bug60049
--- /mnt/data/home/alexey.kopytov/src/percona/5.5.11/Percona-Server/mysql-test/suite/innodb/r/innodb_bug60049.result 2011-03-31 16:36:17.000000000 +0300
+++ /mnt/data/home/alexey.kopytov/src/percona/5.5.11/Percona-Server/mysql-test/suite/innodb/r/innodb_bug60049.reject 2011-04-10 12:11:00.000000000 +0300
@@ -5,4 +5,4 @@
 @@innodb_fast_shutdown
 0
 Last record of ID_IND root page (9):
-1808000018050074000000000000000c5359535f464f524549474e5f434f4c53
+18080000180500c0000000000000000c5359535f464f524549474e5f434f4c53

mysqltest: Result content mismatch

Changed in percona-projects-qa:
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
status: New → Confirmed
Changed in percona-projects-qa:
importance: Undecided → High

It is bug of the purge_thread.
It seems to be that there are some records not-purged after shutdown, even if with inondb_fast_shutdown=0.

And this problem is caused also for normal 5.5.11 with innodb_purge_threads=1

I will investigate and fix soon.

fixed at rev. 104 of 5.5.11/ directly

Changed in percona-projects-qa:
status: Confirmed → Fix Committed
Changed in percona-projects-qa:
status: Fix Committed → Fix Released

The symptoms of this bug have resurfaced again:
http://jenkins.percona.com/view/Percona%20Server%205.5/job/percona-server-5.5-trunk/BUILD_TYPE=release,Host=centos6-64/74/testReport/junit/%28root%29/innodb/innodb_bug60049/

Comment:

Logfile:
CURRENT_TEST: innodb.innodb_bug60049
--- /home/jenkins/workspace/percona-server-5.5-trunk/BUILD_TYPE/release/Host/centos6-64/Percona-Server-5.5.17-rel21.0/mysql-test/suite/innodb/r/innodb_bug60049.result 2011-10-12 15:10:25.000000000 +0300
+++ /home/jenkins/workspace/percona-server-5.5-trunk/BUILD_TYPE/release/Host/centos6-64/Percona-Server-5.5.17-rel21.0/mysql-test/suite/innodb/r/innodb_bug60049.reject 2011-11-17 15:15:06.528222320 +0300
@@ -5,4 +5,4 @@
 @@innodb_fast_shutdown
 0
 Last record of ID_IND root page (9):
-1808000018050074000000000000000c5359535f464f524549474e5f434f4c53
+18080000180500d6000000000000000c5359535f464f524549474e5f434f4c53

mysqltest: Result content mismatch

Changed in percona-projects-qa:
assignee: Yasufumi Kinoshita (yasufumi-kinoshita) → nobody
affects: percona-projects-qa → percona-server
Kristian Nielsen (knielsen) wrote :

Also seen in MariaDB 5.5 (with XtraDB). It is not repeatable on all hosts and/or build-options though

Changed in maria:
milestone: none → 5.5
status: New → Confirmed
Stewart Smith (stewart) wrote :

Can we still repeat this anywhere? I'm not seeing it in our recent jenkins builds.

Changed in maria:
status: Confirmed → Incomplete
tags: added: xtradb
summary: - The innodb.innodb_bug60049 test fails in 5.5.11
+ Intermittent innodb.innodb_bug60049 test failures
tags: added: ci

No failures in the last 2-3 months in Jenkins trunk builds across 5.1/5.5/5.6.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-1853

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers