rename enable_query_response_time option in 5.5

Bug #714884 reported by Vadim Tkachenko on 2011-02-07
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to
Fix Released
Oleg Tsarev

Bug Description

We should rename enable_query_response_time to query_response_time in Percona Server 5.5 and make sure it works as boolean variable in my.cnf and command line.

Related branches

Changed in percona-server:
importance: Undecided → High
milestone: none → 5.5-20beta
Changed in percona-server:
assignee: nobody → Oleg Tsarev (tsarev)
Oleg Tsarev (tsarev) on 2011-02-08
Changed in percona-server:
status: New → In Progress
Oleg Tsarev (tsarev) wrote :


I think you mean:
This is OK, what we have same name to INFORMATION_SCHEMA.QUERY_RESPONSE_TIME?

Oleg Tsarev (tsarev) on 2011-02-08
Changed in percona-server:
status: In Progress → Fix Committed

I think that the name "query_response_time" might be too generic, and
could conflict or be confusing with additional features in the future.
 We might create many ways to measure query response time, and they
could all potentially be described as "query_response_time". I
propose "aggregate_query_response_time". (It is hard to find a good

Vadim Tkachenko (vadim-tk) wrote :


"query_response_time_histogram" or "query_response_time_distribution" ?

Baron Schwartz (baron-xaprb) wrote :

Vadim, I like query_response_time_histogram.

Changed in percona-server:
status: Fix Committed → Fix Released

Percona now uses JIRA for bug reports so this bug report is migrated to:

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers