Percona Server with XtraDB

Add more information from LOG section to SHOW STATUS

Reported by Vadim Tkachenko on 2010-12-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Medium
Unassigned

Bug Description

I'd like to have this stats from SHOW ENGINE INNODB STATUS
---
LOG
---
Log sequence number 122736736141
Log flushed up to 122735266123
Last checkpoint at 121662927923
Max checkpoint age 6957135914
Checkpoint age target 6739725417
Modified age 1054186954
Checkpoint age 1073808218
0 pending log writes, 0 pending chkp writes

available in
SHOW STATUS

For both 5.5 and 5.1

Changed in percona-server:
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
importance: Undecided → Medium
milestone: none → 5.5-20beta
status: New → Confirmed

Vadim,

As I understand we see MySQL 5.5 is released and it does not add a lot of
status values from show innodb status to show status

Why do not we go over show innodb status and get list of all items which we
want exported ? It is probably easy enough to do it at once instead
of in many bits and pieces ?

On Tue, Dec 21, 2010 at 9:21 PM, Vadim Tkachenko <email address hidden> wrote:

> Public bug reported:
>
> I'd like to have this stats from SHOW ENGINE INNODB STATUS
> ---
> LOG
> ---
> Log sequence number 122736736141
> Log flushed up to 122735266123
> Last checkpoint at 121662927923
> Max checkpoint age 6957135914
> Checkpoint age target 6739725417
> Modified age 1054186954
> Checkpoint age 1073808218
> 0 pending log writes, 0 pending chkp writes
> 295762 log i/o's done, 3201.80 log i/o's/second
>
> available in
> SHOW STATUS
>
> For both 5.5 and 5.1
>
> ** Affects: percona-server
> Importance: Medium
> Assignee: Yasufumi Kinoshita (yasufumi-kinoshita)
> Status: Confirmed
>
> ** Changed in: percona-server
> Importance: Undecided => Medium
>
> ** Changed in: percona-server
> Status: New => Confirmed
>
> ** Changed in: percona-server
> Milestone: None => 5.5-20beta
>
> ** Changed in: percona-server
> Assignee: (unassigned) => Yasufumi Kinoshita (yasufumi-kinoshita)
>
> --
> You received this bug notification because you are a member of Percona
> developers, which is the registrant for Percona Server.
> https://bugs.launchpad.net/bugs/693269
>
> Title:
> Add more information from LOG section to SHOW STATUS
>
> Status in Percona Server with XtraDB:
> Confirmed
>
> Bug description:
> I'd like to have this stats from SHOW ENGINE INNODB STATUS
> ---
> LOG
> ---
> Log sequence number 122736736141
> Log flushed up to 122735266123
> Last checkpoint at 121662927923
> Max checkpoint age 6957135914
> Checkpoint age target 6739725417
> Modified age 1054186954
> Checkpoint age 1073808218
> 0 pending log writes, 0 pending chkp writes
> 295762 log i/o's done, 3201.80 log i/o's/second
>
> available in
> SHOW STATUS
>
> For both 5.5 and 5.1
>
>
>

--
Peter Zaitsev, CEO, Percona Inc.
Tel: +1 888 401 3401 ext 501 Skype: peter_zaitsev
24/7 Emergency Line +1 888 401 3401 ext 911

Percona Training Workshops
http://www.percona.com/training/

Vadim Tkachenko (vadim-tk) wrote :
Download full text (3.6 KiB)

Because it requires good amount of time to have all that parsed and added.
If you can provide FULL list of status variables that should be added, that may
help to get this happened.

On Tue, Dec 21, 2010 at 9:41 PM, Peter Zaitsev <email address hidden> wrote:
> Vadim,
>
> As I understand we see MySQL 5.5 is released and it does not add a lot of
> status values from show innodb status to show status
>
> Why do not we go over show innodb status and get list of all items which we
> want exported ?  It is probably easy enough to do it at once instead
> of in many bits and pieces ?
>
>
> On Tue, Dec 21, 2010 at 9:21 PM, Vadim Tkachenko <email address hidden>
> wrote:
>
>> Public bug reported:
>>
>> I'd like to have this stats from SHOW ENGINE INNODB STATUS
>> ---
>> LOG
>> ---
>> Log sequence number 122736736141
>> Log flushed up to   122735266123
>> Last checkpoint at  121662927923
>> Max checkpoint age    6957135914
>> Checkpoint age target 6739725417
>> Modified age          1054186954
>> Checkpoint age        1073808218
>> 0 pending log writes, 0 pending chkp writes
>> 295762 log i/o's done, 3201.80 log i/o's/second
>>
>> available in
>> SHOW STATUS
>>
>> For both 5.5 and 5.1
>>
>> ** Affects: percona-server
>>     Importance: Medium
>>     Assignee: Yasufumi Kinoshita (yasufumi-kinoshita)
>>         Status: Confirmed
>>
>> ** Changed in: percona-server
>>   Importance: Undecided => Medium
>>
>> ** Changed in: percona-server
>>       Status: New => Confirmed
>>
>> ** Changed in: percona-server
>>    Milestone: None => 5.5-20beta
>>
>> ** Changed in: percona-server
>>     Assignee: (unassigned) => Yasufumi Kinoshita (yasufumi-kinoshita)
>>
>> --
>> You received this bug notification because you are a member of Percona
>> developers, which is the registrant for Percona Server.
>> https://bugs.launchpad.net/bugs/693269
>>
>> Title:
>>  Add more information from LOG section to SHOW STATUS
>>
>> Status in Percona Server with XtraDB:
>>  Confirmed
>>
>> Bug description:
>>  I'd like to have this stats from SHOW ENGINE INNODB STATUS
>> ---
>> LOG
>> ---
>> Log sequence number 122736736141
>> Log flushed up to   122735266123
>> Last checkpoint at  121662927923
>> Max checkpoint age    6957135914
>> Checkpoint age target 6739725417
>> Modified age          1054186954
>> Checkpoint age        1073808218
>> 0 pending log writes, 0 pending chkp writes
>> 295762 log i/o's done, 3201.80 log i/o's/second
>>
>> available in
>> SHOW STATUS
>>
>> For both 5.5 and 5.1
>>
>>
>>
>
>
> --
> Peter Zaitsev, CEO, Percona Inc.
> Tel: +1 888 401 3401 ext 501   Skype:  peter_zaitsev
> 24/7 Emergency Line +1 888 401 3401 ext 911
>
> Percona Training Workshops
> http://www.percona.com/training/
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/693269
>
> Title:
>  Add more information from LOG section to SHOW STATUS
>
> Status in Percona Server with XtraDB:
>  Confirmed
>
> Bug description:
>  I'd like to have this stats from SHOW ENGINE INNODB STATUS
> ---
> LOG
> ---
> Log sequence number 122736736141
> Log flushed up to   122735266123
> Last checkpoint at  121662927923
> Max checkpoint age    69571359...

Read more...

description: updated

This type of data needs to obtain internal mutex to get the values. (log_sys->mutex for this case, because "age" is relative data of 2 values)

Currently, the values of the "show status" doesn't obtain any internal mutex other than "&srv_innodb_monitor_mutex" (at least 5.5.8).

I think we should not add values which needs other internal mutex to get the value.

(unwilling deadlock, or performance problem by "show status" might be occur)

Or, completely wrong value is acceptable?

Vadim Tkachenko (vadim-tk) wrote :

Yasufumi,

It is acceptable to show these values without mutex.

Changed in percona-server:
status: Confirmed → In Progress

Only "Max checkpoint age" needs several mutexes.
So it should not ignore the mutexes and it should not be added to SHOW STATUS.
Others were added.

Changed in percona-server:
status: In Progress → Fix Committed
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers