Percona Server with XtraDB

wrong value for log_slow_verbosity

Reported by Peter Zaitsev on 2010-12-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
High
Oleg Tsarev

Bug Description

In 11.7

mysql> select @@log_slow_verbosity;
+----------------------+
| @@log_slow_verbosity |
+----------------------+
| microtime |
+----------------------+
1 row in set (0.00 sec)

This is when starting server with
log_slow_verbosity="full"

The log file in this case is reporting some strange mix:

# Time: 101216 19:08:01
# User@Host: root[root] @ localhost []
# Thread_id: 4 Schema: Last_errno: 0 Killed: 0
# Query_time: 50.000274 Lock_time: 0.000000 Rows_sent: 1 Rows_examined: 0 Rows_affected: 0 Rows_read: 1
# Bytes_sent: 64 Tmp_tables: 0 Tmp_disk_tables: 0 Tmp_table_sizes: 0
SET timestamp=1292526481;
select sleep(50);

It is not just standard mysql slow log format but it is not the full format (error code, innodb stats etc) either.

Changed in percona-server:
assignee: nobody → Oleg Tsarev (tsarev)
importance: Undecided → High
Oleg Tsarev (tsarev) on 2010-12-16
Changed in percona-server:
status: New → Confirmed

Oleg,

Based on our conversation today as I understand it is actually 2 different
bugs (please feel free to fork it)

1) when use_global_long_query_time is entered on its own line in my.cnf it
is recognized as the second line for it is a parameter for it. It did not
allow such syntax (which I think is should as many boolean variables like
innodb_file_per_table). But what is worse it did not complain about the
incorrect option.

2) There is a problem with "microtime" reporting non standard things in slow
query log. The goal is for log time by default to be absolutely same as in
mysql 5.1 which would allow to use tools only supporting such log files with
Percona.

On Thu, Dec 16, 2010 at 11:45 AM, Oleg Tsarev <email address hidden>wrote:

> ** Changed in: percona-server
> Status: New => Confirmed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/691234
>
> Title:
> wrong value for log_slow_verbosity
>
> Status in Percona Server with XtraDB:
> Confirmed
>
> Bug description:
> In 11.7
>
> mysql> select @@log_slow_verbosity;
> +----------------------+
> | @@log_slow_verbosity |
> +----------------------+
> | microtime |
> +----------------------+
> 1 row in set (0.00 sec)
>
>
>
> This is when starting server with
> log_slow_verbosity="full"
>
> The log file in this case is reporting some strange mix:
>
> # Time: 101216 19:08:01
> # User@Host: root[root] @ localhost []
> # Thread_id: 4 Schema: Last_errno: 0 Killed: 0
> # Query_time: 50.000274 Lock_time: 0.000000 Rows_sent: 1 Rows_examined:
> 0 Rows_affected: 0 Rows_read: 1
> # Bytes_sent: 64 Tmp_tables: 0 Tmp_disk_tables: 0 Tmp_table_sizes: 0
> SET timestamp=1292526481;
> select sleep(50);
>
>
> It is not just standard mysql slow log format but it is not the full format
> (error code, innodb stats etc) either.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/percona-server/+bug/691234/+subscribe
>

--
Peter Zaitsev, CEO, Percona Inc.
Tel: +1 888 401 3401 ext 501 Skype: peter_zaitsev
24/7 Emergency Line +1 888 401 3401 ext 911

Percona Training Workshops
http://www.percona.com/training/

Oleg Tsarev (tsarev) on 2010-12-17
Changed in percona-server:
status: Confirmed → In Progress
Oleg Tsarev (tsarev) on 2010-12-22
Changed in percona-server:
status: In Progress → Fix Committed
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers