Percona Server with XtraDB

Make variables aligned

Reported by Peter Zaitsev on 2010-12-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Medium
Oleg Tsarev

Bug Description

Right now if I have --use_global_long_query_time=1 I see:

| use_global_log_slow_control | none |
| use_global_long_query_time | ON

Whis is confusing in understanding how these variables work together and makes hard to check the status from scripts.
I would suggest enabling use_global_long_query_time would simply add the "time" to use_global_log_slow_control and setting it to 0 would remove that in this case we do not get into situation (and explainiung) what happens if you have global time check enabled in one of them but not other.

Oleg Tsarev (tsarev) wrote :

Peter,

What the version of Percona-Server?

Changed in percona-server:
assignee: nobody → Oleg Tsarev (tsarev)
status: New → In Progress
Changed in percona-server:
status: In Progress → Confirmed
importance: Undecided → Low
importance: Low → Wishlist

Hi,

It is 11.6

On Fri, Dec 10, 2010 at 10:40 AM, Oleg Tsarev <email address hidden>wrote:

> Peter,
>
> What the version of Percona-Server?
>
> ** Changed in: percona-server
> Assignee: (unassigned) => Oleg Tsarev (tsarev)
>
> ** Changed in: percona-server
> Status: New => In Progress
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/688643
>
> Title:
> Make variables aligned
>
> Status in Percona Server with XtraDB:
> In Progress
>
> Bug description:
> Right now if I have --use_global_long_query_time=1 I see:
>
> | use_global_log_slow_control | none
> |
> | use_global_long_query_time | ON
>
> Whis is confusing in understanding how these variables work together and
> makes hard to check the status from scripts.
> I would suggest enabling use_global_long_query_time would simply add the
> "time" to use_global_log_slow_control and setting it to 0 would remove that
> in this case we do not get into situation (and explainiung) what happens
> if you have global time check enabled in one of them but not other.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/percona-server/+bug/688643/+subscribe
>

--
Peter Zaitsev, CEO, Percona Inc.
Tel: +1 888 401 3401 ext 501 Skype: peter_zaitsev
24/7 Emergency Line +1 888 401 3401 ext 911

Percona Training Workshops
http://www.percona.com/training/

Changed in percona-server:
milestone: none → 5.5-20beta
importance: Wishlist → Medium
Oleg Tsarev (tsarev) on 2010-12-15
Changed in percona-server:
status: Confirmed → In Progress
Oleg Tsarev (tsarev) on 2010-12-22
Changed in percona-server:
status: In Progress → Fix Committed
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers