Percona Server with XtraDB

test-run and swap_builtin_innodb.patch conflict and run tests for builtin incompatible with plugin with xtradb

Reported by Aleksandr Kuzminsky on 2010-12-02
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Critical
Alexey Kopytov
5.1
Critical
Alexey Kopytov
5.5
Critical
Alexey Kopytov

Bug Description

The innodb test suite is not supposed to be run with InnoDB plugin or XtraDB. In this particular case there are two different versions of the test case in suite/innodb/t/innodb_bug56143.test and suite/innodb_plugin/t/innodb_bug56143.test, because the syntax accepted by the built-in version is not compatible with the plugin.

In MySQL mysql-test-run automatically runs the server with either builtin InnoDB or the the plugin based on the test case contents. In Percona Server, mysql-test-run is confused by innodb_swap_builtin_plugin.patch, so it seems to always run the server with XtraDB regardless of the test case contents.

So there is a problem with mysql-test-run or innodb_swap_builtin_plugin.patch that should be fixed, but this particular test failure is harmless and can be ignored.

innodb.innodb_bug56143 [ fail ]
        Test ended at 2010-12-02 09:30:55

CURRENT_TEST: innodb.innodb_bug56143
mysqltest: At line 13: query 'CREATE TABLE `bug56143` (
`a` int(11) DEFAULT NULL,
`b` int(11) DEFAULT NULL,
`c` int(11) DEFAULT NULL,
KEY `a` (`a`),
KEY `b` (`b`),
KEY `c` (`c`),
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa1` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa10` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa100` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa101` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
....
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa96` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa97` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa98` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL,
CONSTRAINT `aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa99` FOREIGN KEY (`b`) REFERENCES `bug56143` (`b`) ON UPDATE SET NULL
) ENGINE=InnoDB' failed: 1005: Can't create table 'test.bug56143' (errno: 150)

 - saving '/home/buildbot/slaves/percona-server-51-11/RPM_CentOS_4_i386/work/BUILD/Percona-Server/mysql-test/var/log/innodb.innodb_bug56143/' to '/home/buildbot/slaves/percona-server-51-11/RPM_CentOS_4_i386/work/BUILD/Percona-Server/mysql-test/var/log/innodb.innodb_bug56143/'

Retrying test innodb.innodb_bug56143, attempt(2/3)...

Changed in percona-server:
milestone: none → 5.1.53-11.7
Changed in percona-server:
importance: Undecided → High
assignee: nobody → Alexey Kopytov (akopytov)
Changed in percona-server:
status: New → In Progress
Alexey Kopytov (akopytov) wrote :

The innodb test suite is not supposed to be run with InnoDB plugin or XtraDB. In this particular case there are two different versions of the test case in suite/innodb/t/innodb_bug56143.test and suite/innodb_plugin/t/innodb_bug56143.test, because the syntax accepted by the built-in version is not compatible with the plugin.

In MySQL mysql-test-run automatically runs the server with either builtin InnoDB or the the plugin based on the test case contents. In Percona Server, mysql-test-run is confused by innodb_swap_builtin_plugin.patch, so it seems to always run the server with XtraDB regardless of the test case contents.

So there is a problem with mysql-test-run or innodb_swap_builtin_plugin.patch that should be fixed, but this particular test failure is harmless and can be ignored.

Changed in percona-server:
status: In Progress → Confirmed
Changed in percona-server:
milestone: 5.1.53-11.7 → 5.1.53-11.8
Stewart Smith (stewart) wrote :

What is the current status of this bug? Are we still seeing failures?

summary: - innodb.innodb_bug56143 fails on 5.1.53-11.7
+ test-run and swap_builtin_innodb.patch conflict and run tests for
+ builtin incompatible with plugin with xtradb
description: updated
Alexey Kopytov (akopytov) wrote :

Yes, I think it still fails.

Stewart Smith (stewart) wrote :

okay, so is Critical as cannot release with failing tests.

Changed in percona-server:
status: Confirmed → Triaged
importance: High → Critical
Stewart Smith (stewart) on 2011-05-24
Changed in percona-server:
milestone: 5.1.53-11.8 → none
Stewart Smith (stewart) on 2011-06-02
Changed in percona-server:
milestone: none → 5.1.58-12.9
Alexey Kopytov (akopytov) wrote :

Not applicable to 5.5, setting to Invalid.

Alexey Kopytov (akopytov) wrote :

The test case is already disabled in 5.1. Other tests in the 'innodb' suite pass.

But then again, we should not care about the innodb suite, because it is supposed to be run against the server started with built-in InnoDB, which is impossible for Percona Server.

Setting to Fix Released in 5.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers