Percona Server with XtraDB

Package conflict with mysql-mmm-agent and libdbd-mysql-perl

Reported by Marcus Bointon on 2010-11-25
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Wishlist
Unassigned

Bug Description

After switching from an Ubuntu standard package to percona-sql-server 5.0.91-percona-b22.lucid.0, I run into this conflict with mysql-mmm-agent and libdbd-perl-mysql, and an unexpected inkage to percona-server-common:

The following packages are BROKEN:
  percona-sql-client-5.0 percona-sql-server-5.0
The following NEW packages will be installed:
  libmysqlclient16{a} percona-server-common{a}
The following packages will be REMOVED:
  percona-sql-common{a}
The following packages will be upgraded:
  libdbd-mysql-perl
1 packages upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 2,006kB of archives. After unpacking 4,284kB will be used.
The following packages have unmet dependencies:
  percona-sql-server-5.0: PreDepends: percona-sql-common but it is not installable
  percona-sql-client-5.0: Depends: percona-sql-common but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
libdbd-mysql-perl
mysql-mmm-agent

Keep the following packages at their current version:
libmysqlclient16 [Not Installed]
percona-server-common [Not Installed]
percona-sql-common [5.0.91-percona-b22.lucid.0 (<NULL>, now)]

Percona (percona-team) on 2010-11-25
Changed in percona-server:
importance: Undecided → Wishlist
Kenny Gryp (gryp) wrote :

There's no need to have libmysqlclient16 depend on percona-server-common.

Changed in percona-server:
status: New → Fix Committed
Stewart Smith (stewart) wrote :

So this looks like it's all resolved and released. Please reopen if is a continuing issue.

Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers