Percona Server with XtraDB

main.percona_query_response_time-stored fails on 5.1.50-rel12.1

Reported by Aleksandr Kuzminsky on 2010-09-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
Undecided
Oleg Tsarev

Bug Description

main.percona_query_response_time-stored [ fail ]
        Test ended at 2010-09-28 12:53:37

CURRENT_TEST: main.percona_query_response_time-stored
--- /mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/r/percona_query_response_time-stored.result 2010-09-28 22:07:28.000000000 +0300
+++ /mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/r/percona_query_response_time-stored.reject 2010-09-28 22:53:36.000000000 +0300
@@ -22,12 +22,13 @@
 Variable_name Value
 query_response_time_range_base 2
 FLUSH QUERY_RESPONSE_TIME;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 44
@@ -76,7 +77,7 @@
  2097152.00000
  4194304.00000
  8388608.00000
-TOO LONG QUERY
+TOO LONG
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=1;
 SELECT test_f();
 test_f()
@@ -91,14 +92,15 @@
 test_f()
 Hello, world!
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
-1 5 2 44
-4 5 2 44
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
+1 5 4 2 44
+4 5 4 2 44
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 44
@@ -147,7 +149,7 @@
  2097152.00000
  4194304.00000
  8388608.00000
-TOO LONG QUERY
+TOO LONG
 SHOW GLOBAL VARIABLES where Variable_name like 'QUERY_RESPONSE_TIME_RANGE_BASE';
 Variable_name Value
 query_response_time_range_base 2
@@ -161,14 +163,15 @@
 test_f()
 Hello, world!
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
-1 2 2 14
-1 2 2 14
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
+1 2 1 2 14
+1 2 1 2 14
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 14
@@ -187,7 +190,7 @@
   10000.000000
  100000.000000
  1000000.00000
-TOO LONG QUERY
+TOO LONG
 SHOW GLOBAL VARIABLES where Variable_name like 'QUERY_RESPONSE_TIME_RANGE_BASE';
 Variable_name Value
 query_response_time_range_base 10
@@ -201,14 +204,15 @@
 test_f()
 Hello, world!
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
-1 2 2 17
-1 2 2 17
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
+1 2 1 2 17
+1 2 1 2 17
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 17
@@ -230,7 +234,7 @@
  117649.000000
  823543.000000
  5764801.00000
-TOO LONG QUERY
+TOO LONG
 SHOW GLOBAL VARIABLES where Variable_name like 'QUERY_RESPONSE_TIME_RANGE_BASE';
 Variable_name Value
 query_response_time_range_base 7
@@ -244,14 +248,15 @@
 test_f()
 Hello, world!
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
-1 2 2 7
-1 2 2 7
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
+1 2 1 2 7
+1 2 1 2 7
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 7
@@ -263,7 +268,7 @@
     156.000000
   24336.000000
  3796416.00000
-TOO LONG QUERY
+TOO LONG
 SHOW GLOBAL VARIABLES where Variable_name like 'QUERY_RESPONSE_TIME_RANGE_BASE';
 Variable_name Value
 query_response_time_range_base 156
@@ -277,14 +282,15 @@
 test_f()
 Hello, world!
 SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
-SELECT c.count,
+SELECT d.count,
 (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
-(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
+(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
+(SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
 (SELECT COUNT(*) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
-FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
-count query_count not_zero_region_count region_count
-1 2 2 6
-1 2 2 6
+FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
+count query_count query_total not_zero_region_count region_count
+1 2 1 2 6
+1 2 1 2 6
 SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
 region_count
 6
@@ -295,7 +301,7 @@
       1.000000
    1000.000000
  1000000.00000
-TOO LONG QUERY
+TOO LONG
 SHOW GLOBAL VARIABLES where Variable_name like 'QUERY_RESPONSE_TIME_RANGE_BASE';
 Variable_name Value
 query_response_time_range_base 1000

mysqltest: Result content mismatch

 - saving '/mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/var/log/main.percona_query_response_time-stored/' to '/mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/var/log/main.percona_query_response_time-stored/'

Changed in percona-server:
milestone: none → 5.1.50-12.1
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)
assignee: Aleksandr Kuzminsky (akuzminsky) → Oleg Tsarev (tsarev)
Oleg Tsarev (tsarev) on 2010-09-30
Changed in percona-server:
status: New → Fix Committed
Stewart Smith (stewart) wrote :

should this be fix released?

Download full text (10.3 KiB)

Stewart,

According to our bug process documentation propose for merge should be
approved by reviewers. After that bug has status "fix confirmed"
(internal status) and will merge to branch.
When release will released we change status to "Fix released".

Better ask Valentine about this.

Oleg.

2011/5/26 Stewart Smith <email address hidden>:
> should this be fix released?
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/650977
>
> Title:
>  main.percona_query_response_time-stored fails on 5.1.50-rel12.1
>
> Status in Percona Server with XtraDB:
>  Fix Committed
>
> Bug description:
>  main.percona_query_response_time-stored  [ fail ]
>          Test ended at 2010-09-28 12:53:37
>
>  CURRENT_TEST: main.percona_query_response_time-stored
>  --- /mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/r/percona_query_response_time-stored.result   2010-09-28 22:07:28.000000000 +0300
>  +++ /mnt/data1/home/buildbot/slaves/percona-server-51-12/sm1u02/build/Percona-Server/mysql-test/r/percona_query_response_time-stored.reject   2010-09-28 22:53:36.000000000 +0300
>  @@ -22,12 +22,13 @@
>   Variable_name        Value
>   query_response_time_range_base       2
>   FLUSH QUERY_RESPONSE_TIME;
>  -SELECT c.count,
>  +SELECT d.count,
>   (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
>  -(SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
>  +(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
>  +(SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
>   (SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME) as region_count
>  -FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count > 0;
>  -count        query_count     not_zero_region_count   region_count
>  +FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as d WHERE d.count > 0;
>  +count        query_count     query_total     not_zero_region_count   region_count
>   SELECT COUNT(*) as region_count FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME;
>   region_count
>   44
>  @@ -76,7 +77,7 @@
>    2097152.00000
>    4194304.00000
>    8388608.00000
>  -TOO LONG QUERY
>  +TOO LONG
>   SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=1;
>   SELECT test_f();
>   test_f()
>  @@ -91,14 +92,15 @@
>   test_f()
>   Hello, world!
>   SET GLOBAL ENABLE_QUERY_RESPONSE_TIME_STATS=0;
>  -SELECT c.count,
>  +SELECT d.count,
>   (SELECT SUM(a.count) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as a WHERE a.count != 0) as query_count,
>  -(SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as not_zero_region_count,
>  +(SELECT SUM((b.total * 1000000) DIV 1000000) FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as b WHERE b.count != 0) as query_total,
>  +(SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPONSE_TIME as c WHERE c.count != 0) as not_zero_region_count,
>   (SELECT COUNT(*)     FROM INFORMATION_SCHEMA.QUERY_RESPON...

Stewart Smith (stewart) wrote :

or should this be fix released?

Changed in percona-server:
milestone: 5.1.50-12.1 → none
Oleg Tsarev (tsarev) on 2011-06-24
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers