Percona Server with XtraDB

Crash with innodb_doublewrite_file

Reported by Vadim Tkachenko on 2010-09-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
High
Unassigned

Bug Description

I've got crash specifying innodb_doublewrite_file on existing database:

InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use GCC atomic builtins
InnoDB: Compressed tables use zlib 1.2.3
InnoDB: Notice: innodb_doublewrite_file is specified.
InnoDB: This is for expert only. Don't use if you don't understand what is it 'WELL'.
InnoDB: ### Don't specify older file than the last checkpoint ###
InnoDB: otherwise the older doublewrite buffer will break your data during recovery!
100915 17:04:01 InnoDB: Doublewrite buffer file /data/ibd_dblw.ibd did not exist: new to be created
InnoDB: Warning: Previous version's ibdata files may cause crash.
        If you use that, please use the ibdata files of this version.
100915 17:04:01 InnoDB: Setting file /data/ibd_dblw.ibd size to 9 MB
InnoDB: Database physically writes the file full: wait...
5
100915 17:04:01 InnoDB: highest supported file format is Barracuda.
InnoDB: doublewrite file '/data/ibd_dblw.ibd' is used.
InnoDB: Doublewrite buffer not found in the doublewrite file: creating new
100915 17:04:10 InnoDB: ERROR: the age of the last checkpoint is 327711929534,
InnoDB: which exceeds the log group capacity 5798202164.
InnoDB: If you are using big BLOB or TEXT rows, you must set the
InnoDB: combined size of log files at least 10 times bigger than the
InnoDB: largest such row.
InnoDB: Doublewrite buffer created in the doublewrite file
100915 17:04:10 Percona XtraDB (http://www.percona.com) 1.0.10-12.0 started; log sequence number 327711934066
100915 17:04:10 [Note] /usr/local/mysql/libexec/mysqld: ready for connections.
Version: '5.1.49-rel12.0' socket: '/tmp/mysql.sock' port: 3306 Percona Server with XtraDB (GPL), Release 12.0, Revision 109
100915 17:04:11 InnoDB: Assertion failure in thread 1104005440 in file ibuf/ibuf0ibuf.c line 1107
InnoDB: Failing assertion: trx_sys_multiple_tablespace_format
InnoDB: We intentionally generate a memory trap.
InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
InnoDB: If you get repeated assertion failures or crashes, even
InnoDB: immediately after the mysqld startup, there may be
InnoDB: corruption in the InnoDB tablespace. Please refer to
InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
InnoDB: about forcing recovery.
100915 17:04:11 - mysqld got signal 6 ;
This could be because you hit a bug. It is also possible that this binary
or one of the libraries it was linked against is corrupt, improperly built,
or misconfigured. This error can also be caused by malfunctioning hardware.
We will try our best to scrape up some info that will hopefully help diagnose
the problem, but since we have already crashed, something is definitely wrong
and this may fail.

key_buffer_size=8384512
read_buffer_size=131072
max_used_connections=0
max_threads=3000
threads_connected=0
It is possible that mysqld could use up to
key_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 6568555 K
bytes of memory
Hope that's ok; if not, decrease some variables in the equation.

thd: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = (nil) thread_stack 0x40000
/usr/local/mysql/libexec/mysqld(my_print_stacktrace+0x35)[0x8731a5]
/usr/local/mysql/libexec/mysqld(handle_segfault+0x322)[0x5b1902]
/lib64/libpthread.so.0[0x3d2760eb10]
/lib64/libc.so.6(gsignal+0x35)[0x3d26e30265]
/lib64/libc.so.6(abort+0x110)[0x3d26e31d10]
/usr/local/mysql/libexec/mysqld[0x73b367]
/usr/local/mysql/libexec/mysqld[0x741520]
/usr/local/mysql/libexec/mysqld[0x741f1f]
/usr/local/mysql/libexec/mysqld[0x7420ae]
/usr/local/mysql/libexec/mysqld[0x797891]
/lib64/libpthread.so.0[0x3d2760673d]
/lib64/libc.so.6(clone+0x6d)[0x3d26ed3d1d]

Related branches

Changed in percona-server:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Yasufumi Kinoshita (yasufumi-kinoshita)
milestone: none → 5.1-13.0

This is assertion error about "insert buffer". not about "doublewrite buffer".
I can say nothing from such small information.
I suspect it may not related to the option.

The datafiles of XtraDB should be created by after the version which includes the innodb_doublewrite_file already.
But the assertion error for the such old datafiles should be more clear.

Vadim Tkachenko (vadim-tk) wrote :

I think it happens if innodb_fast_shutdown=1 ( default), and when
InnoDB shutdowns it has unmerged insert_buffer.

Changed in percona-server:
status: Confirmed → Fix Committed
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers