Percona Server with XtraDB

EditLine used for percona-server-client-5.1 on ubuntu

Reported by Przemek on 2010-09-06
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Percona Server
Wishlist
Ignacio Nin
Ubuntu
Undecided
Unassigned

Bug Description

Why do you replicate so big mistake made by Ubuntu guys by using EditLine instead of readline for mysql client 5.1 ?

Current 5.1 percona client version for Ubuntu won't let you use ctrl+r for searching commandline history, and browsing using up arrowkey is no longer distinct ! This makes mysql client really pain in the ass.

But still the same version for Redhat use readline, why ubuntu users have to be punished so badly ?

redhat:
Percona-Server-client-51-5.1.47-rel11.2.53.rhel5.x86_64
mysql --version
mysql Ver 14.14 Distrib 5.1.47, for unknown-linux-gnu (x86_64) using readline 5.1

ubuntu:
percona-sql-client-5.0 5.0.91-percona-b22.karmic.16
mysql --version
mysql Ver 14.12 Distrib 5.0.91, for debian-linux-gnu (x86_64) using readline 6.0

percona-server-client-5.1 5.1.47-11.1-51.karmic
mysql --version
mysql Ver 14.14 Distrib 5.1.47, for debian-linux-gnu (x86_64) using EditLine wrapper

And debian repository mysql-client still uses readline.

Please use readline back in the next 5.1 client release.

Related branches

lp:~percona-dev/percona-server/release-5.1.55-12
Vadim Tkachenko: Approve on 2011-03-10
Fred Linhoss (community): Approve (documentation) on 2011-03-10
Przemek (pmalkowski) on 2010-09-07
tags: added: 5.1 ubuntu
Changed in ubuntu:
status: New → Invalid
Przemek (pmalkowski) wrote :

Just wanted to mention that Lucid ubuntu version has readline again:

mysql --version
mysql Ver 14.14 Distrib 5.1.41, for debian-linux-gnu (i486) using readline 6.1

So why not fix percona packages too ?

Percona (percona-team) on 2010-11-25
Changed in percona-server:
status: New → Confirmed
importance: Undecided → Wishlist
Bart Verwilst (verwilst) wrote :

one-line fix: add --without-readline to the configure options and recompile.

Bart Verwilst (verwilst) wrote :

To elaborate, the added flag above seems to be contradicting the solution, but it's just a badly chosen name:

" --without-readline Use system readline instead of bundled copy."

Proof here:

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 43
Server version: 5.1.54-rel12.5 (Percona Server (GPL), 12.5 )

Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.
This software comes with ABSOLUTELY NO WARRANTY. This is free software,
and you are welcome to modify and redistribute it under the GPL v2 license

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> select version();
+----------------+
| version() |
+----------------+
| 5.1.54-rel12.5 |
+----------------+
1 row in set (0.00 sec)

(reverse-i-search)`se': select version();

Delete key also works fine, but that's heard to show in a copy-paste :)

Changed in percona-server:
assignee: nobody → Ignacio Nin (ignacio-nin)
Ignacio Nin (ignacio-nin) wrote :

Added --with-readline (in order to follow our RPM usage) to the configure line of the control file in the release-5.1.55-12 branch (commit #201). Now the mysql binary is built with readline support.

Changed in percona-server:
status: Confirmed → Fix Committed
Bart Verwilst (verwilst) wrote :

--with-readline uses the bundled copy of readline, which is why i used --without-readline to get to a working build.

As seen on the newly released 5.1.54-rel12.5 packages:

"mysql Ver 14.14 Distrib 5.1.55, for debian-linux-gnu (x86_64) using EditLine wrapper"

As seen on the packages i built with --without-readline:

"mysql Ver 14.14 Distrib 5.1.54, for debian-linux-gnu (x86_64) using readline 5.2"

As a result, this still isn't fixed.

Changed in percona-server:
status: Fix Committed → Confirmed
Ignacio Nin (ignacio-nin) wrote :

Hello Bart,

The recently distributed binaries correspond to commit 200, and this was fixed in commit 201, so unfortunately these binaries don't include this fix.

Nevertheless, the fix was commited and a binary with the fix can be built from the tip of release-5.1.55-20 or the main branch soon (and will be released in 5.1.56). This is why I set bug was set to "fix commited", please notice it's not "fix released". When 5.1.56 is released we'll switch to fix released.

Switching back to "fix commited". Thanks,

N.

Changed in percona-server:
status: Confirmed → Fix Committed
Bart Verwilst (verwilst) wrote :

Hi Ignacio,

Thanks for the explanation, you're absolutely right, thanks for fixing :) Now to play the waiting game for 5.1.56.. ;)

Przemek (pmalkowski) wrote :

mysql --version
mysql Ver 14.14 Distrib 5.1.56, for debian-linux-gnu (x86_64) using readline 5.1

Thanks guys, mysql client for ubuntu is awesome again!

Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers