Percona Server with XtraDB

CentOS 5: mysql-server conflicts with MySQL-server

Reported by Artem Petakov on 2010-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server
High
Aleksandr Kuzminsky

Bug Description

Followed these instructions: http://www.mysqlperformanceblog.com/2010/03/14/percona-xtradb-version-9-1/

------------------------------------
[artem@www tmp]$ sudo yum install Percona-XtraDB-server Percona-XtraDB-client
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
 * epel: mirrors.tummy.com
 * updates: mirrors.netdna.com
 * base: mirrors.tummy.com
 * addons: mirrors.netdna.com
 * percona: repo.percona.com
 * extras: mirror.raystedman.net
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package Percona-XtraDB-client-51.x86_64 0:5.1.45-10.rhel5 set to be updated
--> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit) for package: Percona-XtraDB-client-51
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: Percona-XtraDB-client-51
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: Percona-XtraDB-client-51
--> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package: Percona-XtraDB-client-51
---> Package Percona-XtraDB-server-51.x86_64 0:5.1.45-10.rhel5 set to be updated
--> Running transaction check
---> Package MySQL-shared-compat.x86_64 0:5.1.40-2 set to be updated
--> Processing Conflict: mysql conflicts MySQL
--> Processing Conflict: mysql conflicts MySQL
--> Processing Conflict: mysql-server conflicts MySQL-server
--> Finished Dependency Resolution
Error: mysql conflicts with MySQL
Error: mysql-server conflicts with MySQL-server
-------------------------------

Artem,

Could you please show the output of "rpm -qa | grep -i -e mysql -e percona" ?

Changed in percona-xtradb:
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)

Of course there are many comments about this https://answers.launchpad.net/ourdelta/+question/68202
But is there any way to do this on a running machine with php-mysql already serving stuff? So I can't uninstall it to start over.

Thank you, Aleksandr.

rpm -qa | grep -i -e mysql -e percona

libdbi-dbd-mysql-0.8.1a-1.2.2
mod_auth_mysql-3.0.0-3.1
mysql-5.0.77-4.el5_4.2
mysql-5.0.77-4.el5_4.2
mysql-connector-odbc-3.51.12-2.2
MySQL-python-1.2.1-1
php-pear-MDB2-Driver-mysql-1.4.1-3.el5.centos
php-mysql-5.2.6-1.el5.remi
perl-DBD-MySQL-3.0007-1.fc6

Changed in percona-xtradb:
status: New → Triaged
importance: Undecided → High
affects: percona-xtradb → percona-server
Changed in percona-server:
milestone: none → 5.1.46-rel10.1

I've confirmed that doing a "yum remove mysql" (and removing all of the
dependent components too), then installing the Percona Server, Client (and
thus Compat) packages and then re-installing all of the components does
work. But is there a way to make this work without such a complex procedure?
I think it would be good to fix this given that this is on a standard CentOS
5 install.

Artem

On Sat, Apr 24, 2010 at 12:23 AM, Vadim Tkachenko <email address hidden> wrote:

> ** Changed in: percona-xtradb
> Status: New => Triaged
>
> ** Changed in: percona-xtradb
> Importance: Undecided => High
>
> ** Project changed: percona-xtradb => percona-server
>
> ** Changed in: percona-server
> Milestone: None => 5.1.46-rel10.1
>
> --
> CentOS 5: mysql-server conflicts with MySQL-server
> https://bugs.launchpad.net/bugs/569156
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Percona Server with XtraDB: Triaged
>
> Bug description:
> Followed these instructions:
> http://www.mysqlperformanceblog.com/2010/03/14/percona-xtradb-version-9-1/
>
> ------------------------------------
> [artem@www tmp]$ sudo yum install Percona-XtraDB-server
> Percona-XtraDB-client
> Loading "fastestmirror" plugin
> Loading mirror speeds from cached hostfile
> * epel: mirrors.tummy.com
> * updates: mirrors.netdna.com
> * base: mirrors.tummy.com
> * addons: mirrors.netdna.com
> * percona: repo.percona.com
> * extras: mirror.raystedman.net
> Setting up Install Process
> Parsing package install arguments
> Resolving Dependencies
> --> Running transaction check
> ---> Package Percona-XtraDB-client-51.x86_64 0:5.1.45-10.rhel5 set to be
> updated
> --> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
> for package: Percona-XtraDB-client-51
> --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit)
> for package: Percona-XtraDB-client-51
> --> Processing Dependency: libmysqlclient.so.16()(64bit) for package:
> Percona-XtraDB-client-51
> --> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package:
> Percona-XtraDB-client-51
> ---> Package Percona-XtraDB-server-51.x86_64 0:5.1.45-10.rhel5 set to be
> updated
> --> Running transaction check
> ---> Package MySQL-shared-compat.x86_64 0:5.1.40-2 set to be updated
> --> Processing Conflict: mysql conflicts MySQL
> --> Processing Conflict: mysql conflicts MySQL
> --> Processing Conflict: mysql-server conflicts MySQL-server
> --> Finished Dependency Resolution
> Error: mysql conflicts with MySQL
> Error: mysql-server conflicts with MySQL-server
> -------------------------------
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/percona-server/+bug/569156/+subscribe
>

Vadim Tkachenko (vadim-tk) wrote :
Download full text (5.0 KiB)

Artem,

We are going to remove
Obsolotes: mysql mysql-server

from further RPM packages, it should fix the problem.

On Mon, Apr 26, 2010 at 12:56 PM, Artem Petakov <email address hidden> wrote:
> I've confirmed that doing a "yum remove mysql" (and removing all of the
> dependent components too), then installing the Percona Server, Client (and
> thus Compat) packages and then re-installing all of the components does
> work. But is there a way to make this work without such a complex procedure?
> I think it would be good to fix this given that this is on a standard CentOS
> 5 install.
>
> Artem
>
> On Sat, Apr 24, 2010 at 12:23 AM, Vadim Tkachenko <email address hidden>
> wrote:
>
>> ** Changed in: percona-xtradb
>>       Status: New => Triaged
>>
>> ** Changed in: percona-xtradb
>>   Importance: Undecided => High
>>
>> ** Project changed: percona-xtradb => percona-server
>>
>> ** Changed in: percona-server
>>    Milestone: None => 5.1.46-rel10.1
>>
>> --
>> CentOS 5: mysql-server conflicts with MySQL-server
>> https://bugs.launchpad.net/bugs/569156
>> You received this bug notification because you are a direct subscriber
>> of the bug.
>>
>> Status in Percona Server with XtraDB: Triaged
>>
>> Bug description:
>> Followed these instructions:
>> http://www.mysqlperformanceblog.com/2010/03/14/percona-xtradb-version-9-1/
>>
>> ------------------------------------
>> [artem@www tmp]$ sudo yum install Percona-XtraDB-server
>> Percona-XtraDB-client
>> Loading "fastestmirror" plugin
>> Loading mirror speeds from cached hostfile
>>  * epel: mirrors.tummy.com
>>  * updates: mirrors.netdna.com
>>  * base: mirrors.tummy.com
>>  * addons: mirrors.netdna.com
>>  * percona: repo.percona.com
>>  * extras: mirror.raystedman.net
>> Setting up Install Process
>> Parsing package install arguments
>> Resolving Dependencies
>> --> Running transaction check
>> ---> Package Percona-XtraDB-client-51.x86_64 0:5.1.45-10.rhel5 set to be
>> updated
>> --> Processing Dependency: libmysqlclient_r.so.16(libmysqlclient_16)(64bit)
>> for package: Percona-XtraDB-client-51
>> --> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit)
>> for package: Percona-XtraDB-client-51
>> --> Processing Dependency: libmysqlclient.so.16()(64bit) for package:
>> Percona-XtraDB-client-51
>> --> Processing Dependency: libmysqlclient_r.so.16()(64bit) for package:
>> Percona-XtraDB-client-51
>> ---> Package Percona-XtraDB-server-51.x86_64 0:5.1.45-10.rhel5 set to be
>> updated
>> --> Running transaction check
>> ---> Package MySQL-shared-compat.x86_64 0:5.1.40-2 set to be updated
>> --> Processing Conflict: mysql conflicts MySQL
>> --> Processing Conflict: mysql conflicts MySQL
>> --> Processing Conflict: mysql-server conflicts MySQL-server
>> --> Finished Dependency Resolution
>> Error: mysql conflicts with MySQL
>> Error: mysql-server conflicts with MySQL-server
>> -------------------------------
>>
>> To unsubscribe from this bug, go to:
>> https://bugs.launchpad.net/percona-server/+bug/569156/+subscribe
>>
>
> --
> CentOS 5: mysql-server conflicts with MySQL-server
> https://bugs.launchpad.net/bugs/569156
> You received this bug notification because you are a member of Perc...

Read more...

Changed in percona-server:
status: Triaged → Fix Committed
Changed in percona-server:
milestone: 5.1.46-rel11 → 11.0
Changed in percona-server:
milestone: 11.0-old → 11.0
Changed in percona-server:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers