Percona Server with XtraDB

disable mysql service stop on upgrading

Reported by Alex Samorukov on 2010-04-07
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Percona Server
High
Ignacio Nin
5.1
High
Ignacio Nin

Bug Description

I think it is better to remove mysql restart in the rpm scripts. when i`m doing rpm -Uvh Percona-XtraDB-server-51-5.1.45-10.rhel5.i386.rpm i don`t need to restart mysql, better to do it later manually.

Alex Samorukov (samm-os2) wrote :

just checked - there is no restart in RHEL/CENTOS src.rpm, see http://rpm.pbone.net/index.php3/stat/3/srodzaj/2/search/mysql-5.0.77-3.el5.src.rpm

affects: percona-xtradb → percona-server
Changed in percona-server:
assignee: nobody → Aleksandr Kuzminsky (akuzminsky)
Valentine Gostev (longbow) wrote :

Confirmed. Upgrading binaries requires mysqld restart

Changed in percona-server:
importance: Undecided → Wishlist
status: New → Confirmed
assignee: Aleksandr Kuzminsky (akuzminsky) → Vadim Tkachenko (vadim-tk)
tags: added: 51 fr upgrade
Stewart Smith (stewart) wrote :

restart on package upgrade seems sensible, otherwise just gets confusing at best.

please convince me otherwise :)

Changed in percona-server:
status: Confirmed → Won't Fix
Alex Samorukov (samm-os2) wrote :

Let me try.

1) It is against RHEL policy (look on native mysql-server package)
2) It is too easy to break everything on system update.
3) If user is using plugins or UDF he WILL NEED to recompile them before restart, or server will fail on startup. This is my case, btw.
4) After restart you anyway will need some work, like running mysql_upgrade and checking application.

But 1) is the most important - your package should follow RHEL rules if it is designed for a RHEL system.

Stewart Smith (stewart) wrote :

Convinced me with (1). We should follow packaging rules. Thanks!

Changed in percona-server:
importance: Wishlist → High
status: Won't Fix → Triaged
assignee: Vadim Tkachenko (vadim-tk) → Ignacio Nin (ignacio-nin)
Ignacio Nin (ignacio-nin) wrote :

Should this be extended to not start the server after installation? Our current RPM behaviour is to start the server when we install. It should be removed for symmetry.

Vadim Tkachenko (vadim-tk) wrote :

This behavior is consistent with MySQL RPM packages ( from dev.mysql.com)
I propose we do not change it, hence => Won't fix.

Stewart Smith (stewart) wrote :

Since our aim is to be completely compatible with the MySQL RPM packages, I agree we should Won't Fix this (although arguing to upstream is most welcome)

Changed in percona-server:
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers