Add packages for Debian 9 "Stretch"

Bug #1701895 reported by Marcin Engelmann on 2017-07-02
54
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Fix Released
Undecided
EvgeniyPatlan
Percona XtraDB Cluster moved to https://jira.percona.com/projects/PXC
Fix Released
Undecided
EvgeniyPatlan

Bug Description

Please add packages for Debian 9 "Stretch" (https://www.debian.org/News/2017/20170617 released June 17th) to repository https://repo.percona.com/apt

Thanks!

Tags: pkg Edit Tag help
Sveta Smirnova (svetasmirnova) wrote :

Thank you for the report.

Packages have been added: https://repo.percona.com/apt/dists/stretch/

Changed in percona-server:
status: New → Incomplete
status: Incomplete → Fix Released
status: Fix Released → Invalid
Marcin Engelmann (mengelmann) wrote :

Sveta,

thanks for reply.

Unfortunately in the repository are no packages for percona-server-server (and other percona-server-*), so it is not possible to install natively Percona Server on Debian "stretch".

Please check:
- https://repo.percona.com/apt/dists/stretch/main/binary-amd64/Packages
- https://repo.percona.com/apt/dists/jessie/main/binary-amd64/Packages

Marcin

Changed in percona-server:
status: Invalid → New
Changed in percona-server:
assignee: nobody → Vishal kasle (vishal.percona)
Changed in percona-xtradb-cluster:
assignee: nobody → Vishal kasle (vishal.percona)
Vishal kasle (vishal.percona) wrote :

Installed the repo on local instance and checked for the Percona Server and PXC packages. They are not yet added to the Debian 9 repository. This has also been confirmed from dev. Confirming this bug.

Changed in percona-server:
status: New → Confirmed
Changed in percona-xtradb-cluster:
status: New → Confirmed
Changed in percona-server:
assignee: Vishal kasle (vishal.percona) → nobody
Changed in percona-xtradb-cluster:
assignee: Vishal kasle (vishal.percona) → nobody
tags: added: pkg
Paweł Szreder (pszreder) wrote :

Percona Core members, any news about these packages availability?

Thanks,
Paweł

Showfom (showfom) wrote :

To whom it may concern,

Do you have any ETA for supporting Debian 9 Stretch?

Regards

Jan Sieler (jsieler) wrote :

Is there something new? No way to install any server package on stretch since 2 weeks...

EvgeniyPatlan (evgeniy-patlan) wrote :

Packages for stretch should be available in the upcoming release

Wesley Huang (huang-t) wrote :

Any ETA for the upcoming release?

Jan Sieler (jsieler) wrote :

Interested too, what "upcoming release" means.

nitalaut (nitalaut-gmail) wrote :

Any updates ?

Showfom (showfom) wrote :

Still no packages on Debian 9.1

root@debian ~ # apt-cache search percona*
galera-3 - Replication framework for transactional applications
libcatalyst-component-instancepercontext-perl - Single per-request instances of Catalyst components
libreoffice - office productivity suite (metapackage)
mycli - CLI for MySQL/MariaDB
nagios-plugins-contrib - Plugins for nagios compatible monitoring systems
percona-toolkit - Command-line tools for MySQL and system tasks
percona-release - Package to install Percona gpg key and APT repo
percona-xtrabackup-24 - Open source backup tool for InnoDB and XtraDB
percona-xtrabackup-dbg-24 - Debug symbols for Percona XtraBackup
percona-xtrabackup-test-24 - Test suite for Percona XtraBackup
pmm-client - Percona Monitoring and Management Client

Hrvoje Matijakovic (hrvojem) wrote :

Release is planned for the end of this week or the beginning of the next. Pre-release packages for Percona Server 5.6 and 5.7 are currently in the testing repos.

Isern Palaus (ipalaus) wrote :

End of August and still no PXC available for Stretch? ETA?

EvgeniyPatlan (evgeniy-patlan) wrote :

packages for debian9 Stretch are available

Changed in percona-server:
assignee: nobody → EvgeniyPatlan (evgeniy-patlan)
Changed in percona-xtradb-cluster:
assignee: nobody → EvgeniyPatlan (evgeniy-patlan)
Changed in percona-server:
milestone: none → 5.7.19-18
status: Confirmed → Fix Released
Changed in percona-xtradb-cluster:
status: Confirmed → Fix Released
Changed in percona-server:
milestone: 5.7.20-18 → 5.7.19-17

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PXC-1992

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3717

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers