x.connection_tls_version fails on Ubuntu Precise

Bug #1698996 reported by Laurynas Biveinis on 2017-06-20
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Invalid
Undecided
Unassigned
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

Moved from bug 1697700:

x.connection_tls_version fails on Ubuntu Precise, upstream too:

x.connection_tls_version w4 [ fail ]
        Test ended at 2017-06-14 09:08:09

CURRENT_TEST: x.connection_tls_version
mysqltest: At line 43: command "$MYSQLXTEST --tls-version=TLSv1,TLSv1.2 $XTESTPARAMS 2>&1" failed

Output from before failure:
in main, line 0:ERROR: error:14077102:SSL routines:SSL23_GET_SERVER_HELLO:unsupported protocol (code 2026)
not ok
exec of '/mnt/workspace/mysql-5.7-param/BUILD_TYPE/release/Host/ubuntu-precise-64bit/build/rapid/plugin/x/mysqlxtest --port=13050 --tls-version=TLSv1,TLSv1.2 -u user5_mysqlx --password='auth_string' --file=/tmp/EdR5CJvY47/4/connection_tls_version.tmp --ssl-cipher='DHE-RSA-AES256-SHA' 2>&1' failed, error: 256, status: 1, errno: 0

Not sure if that needs fixing because of Precise being EOL'ed

Tags: ci Edit Tag help

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2278

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers