Test main.percona_show_slave_status_nolock is unstable

Bug #1689998 reported by Laurynas Biveinis on 2017-05-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Invalid
Undecided
Unassigned

Bug Description

On 5.5 trunk:

main.percona_show_slave_status_nolock w1 [ fail ]
        Test ended at 2017-05-09 19:24:55

CURRENT_TEST: main.percona_show_slave_status_nolock
--- /mnt/workspace/percona-server-5.5-trunk/BUILD_TYPE/debug/Host/centos5-32/mysql-test/r/percona_show_slave_status_nolock.result 2017-04-20 22:45:35.000000000 +0300
+++ /mnt/workspace/percona-server-5.5-trunk/BUILD_TYPE/debug/Host/centos5-32/mysql-test/r/percona_show_slave_status_nolock.reject 2017-05-10 02:24:55.000000000 +0300
@@ -43,7 +43,7 @@
 [slave_lock]
 SHOW SLAVE STATUS;
 SET DEBUG_SYNC='now WAIT_FOR signal.after_show_slave_status TIMEOUT 1';
-SIGNAL after SHOW SLAVE STATUS is 'signal.empty'
+SIGNAL after SHOW SLAVE STATUS is 'signal.after_show_slave_status'
 [slave]
 SET DEBUG_SYNC='now SIGNAL signal.empty';
 [slave_nolock]

mysqltest: Result content mismatch

This is caused by SHOW SLAVE STATUS failing to reach signal.after_show_slave_status in 1 second due to a TIMEOUT specifier on a subsequent debug_sync point.

Tags: ci Edit Tag help

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3699

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers