Test rpl.rpl_start_stop_slave is unstable

Bug #1677156 reported by Laurynas Biveinis on 2017-03-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Invalid
Undecided
Unassigned
5.7
Invalid
Undecided
Unassigned

Bug Description

On 5.5 trunk:

pl.rpl_start_stop_slave 'stmt' w3 [ fail ]
        Test ended at 2017-03-27 19:10:43

CURRENT_TEST: rpl.rpl_start_stop_slave
=== SHOW MASTER STATUS ===
---- 1. ----
File slave-bin.000001
Position 107
Binlog_Do_DB
Binlog_Ignore_DB
==========================

=== SHOW SLAVE STATUS ===
---- 1. ----
Slave_IO_State
Master_Host 127.0.0.1
Master_User root
Master_Port 13021
Connect_Retry 1
Master_Log_File master-bin.000001
Read_Master_Log_Pos 4
Relay_Log_File slave-relay-bin.000001
Relay_Log_Pos 4
Relay_Master_Log_File master-bin.000001
Slave_IO_Running No
Slave_SQL_Running Yes
Replicate_Do_DB
Replicate_Ignore_DB
Replicate_Do_Table
Replicate_Ignore_Table
Replicate_Wild_Do_Table
Replicate_Wild_Ignore_Table
Last_Errno 0
Last_Error
Skip_Counter 0
Exec_Master_Log_Pos 4
Relay_Log_Space 107
Until_Condition None
Until_Log_File
Until_Log_Pos 0
Master_SSL_Allowed No
Master_SSL_CA_File
Master_SSL_CA_Path
Master_SSL_Cert
Master_SSL_Cipher
Master_SSL_Key
Seconds_Behind_Master
Master_SSL_Verify_Server_Cert No
Last_IO_Errno 0
Last_IO_Error
Last_SQL_Errno 0
Last_SQL_Error
Replicate_Ignore_Server_Ids
Master_Server_Id 1
=========================
...
mysqltest: In included file "./include/rpl_sync.inc":
included from ./include/rpl_sync.inc at line 149:
included from ./include/rpl_end.inc at line 80:
At line 149: sync_slave_with_master failed: 'select master_pos_wait('master-bin.000001', 107, 300)' returned -1 indicating timeout after 300 seconds

The problem is that the final rpl_end.inc sync is unable to complete if slave is not synced already due to stopped slave I/O thread.

tags: added: ci upstream

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3671

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers