Test innodb.percona_log_arch_expire_sec is unstable

Bug #1676740 reported by Laurynas Biveinis on 2017-03-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Invalid
Undecided
Unassigned

Bug Description

On 5.6 trunk:

innodb.percona_log_arch_expire_sec w1 [ fail ]
        Test ended at 2017-03-24 10:00:06

CURRENT_TEST: innodb.percona_log_arch_expire_sec
mysqltest: At line 23: Test failed. Archived logs have nod been purged.

The result from queries just before the failure was:
call mtr.add_suppression("InnoDB: Resizing redo log");
call mtr.add_suppression("InnoDB: Starting to delete and rewrite log files");
call mtr.add_suppression("InnoDB: New log files created");
call mtr.add_suppression("InnoDB: The log sequence numbers [0-9]+ and [0-9]+ in ibdata files do not match the log sequence number [0-9]+ in the ib_logfiles");
drop table if exists t;
create table t (a int not null) ENGINE=InnoDB;
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t values (1),(2),(3),(4),(5),(6),(7),(8),(9),(10),(11),(12),(13);
insert into t (a) select t1.a from t t1, t t2, t t3 LIMIT 40000;
SET @save_log_arch_expire_sec = @@innodb_log_arch_expire_sec;
SET GLOBAL innodb_log_arch_expire_sec = 1;
insert into t (a) select t1.a from t t1, t t2, t t3 LIMIT 40000;
insert into t (a) select t1.a from t t1, t t2, t t3 LIMIT 40000;
SELECT sleep(4);
sleep(4)
0
safe_process[16218]: Child process: 16219, exit: 1

The cause is that the expired log purge is a background process, and there is no synchronisation.

tags: added: ci log-archiving

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-3667

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers