Test innodb.percona_fast_prefix_index_fetch is unstable

Bug #1676441 reported by Laurynas Biveinis on 2017-03-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

On 5.6 trunk:

innodb.percona_fast_prefix_index_fetch w2 [ fail ]
        Test ended at 2017-03-23 09:40:30

CURRENT_TEST: innodb.percona_fast_prefix_index_fetch
mysqltest: In included file "./include/assert.inc":
included from ./include/assert.inc at line 75:
included from ./suite/innodb/include/prefix_index_only_query_check.inc at line 27:
At line 74: Test assertion failed in assert.inc
...
#
# Test that multi-byte charsets are handled correctly
#
SET NAMES utf8mb4;
CREATE TABLE t1 (
a INT PRIMARY KEY,
b VARCHAR(30) CHARACTER SET UTF8MB4,
INDEX b_idx (b(3))) ENGINE=InnoDB;
INSERT INTO t1 VALUES(1, "aa");
INSERT INTO t1 VALUES(2, "ccc");
INSERT INTO t1 VALUES(3, "až");
# MB charset record obviously shorter than the prefix
SELECT * FROM t1 WHERE b = "aa";
a b
1 aa
include/assert.inc [MB charset record obviously shorter than the prefix: 0 innodb_secondary_index_triggered_cluster_reads]
######## Test assertion failed: MB charset record obviously shorter than the prefix: 0 innodb_secondary_index_triggered_cluster_reads ########
Dumping debug info:
Assertion text: 'MB charset record obviously shorter than the prefix: 0 innodb_secondary_index_triggered_cluster_reads'
Assertion condition: '11 - 10 = 0'
Assertion condition, interpolated: '11 - 10 = 0'
Assertion result: '0'
safe_process[29050]: Child process: 29051, exit: 1

This is caused by prefix index query optimisation being circumvented by advancing max trx id on the secondary index page, which then falls outside the current read view and forces clustered index record read to satisfy MVCC.

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2250

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers