Test innodb.innodb-wl6445 is unstable

Bug #1671123 reported by Laurynas Biveinis on 2017-03-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

On 5.6 trunk:

innodb.innodb-wl6445 w1 [ fail ]
        Test ended at 2017-03-07 09:23:27

CURRENT_TEST: innodb.innodb-wl6445
mysqltest: At line 39: query 'INSERT INTO WL6445.t1 VALUES(3,3)' succeeded - should have failed with errno 1015...

The result from queries just before the failure was:
CREATE DATABASE WL6445;
CREATE TABLE WL6445.t1(c1 INT, c2 INT, INDEX sec_idx(c2)) ENGINE=InnoDB;
INSERT INTO WL6445.t1 VALUES(0,0),(1,1),(2,2);
SHOW CREATE TABLE WL6445.t1;
Table Create Table
t1 CREATE TABLE `t1` (
  `c1` int(11) DEFAULT NULL,
  `c2` int(11) DEFAULT NULL,
  KEY `sec_idx` (`c2`)
) ENGINE=InnoDB DEFAULT CHARSET=latin1
# Request clean shutdown
# Wait for disconect
# Restart server.
# Restarted
SELECT COUNT(*) FROM WL6445.t1;
COUNT(*)
3
safe_process[30300]: Child process: 30301, exit: 1

Server [mysqld.1 - pid: 30272, winpid: 30272] log:
Server log from this test:
----------SERVER LOG START-----------
----------SERVER LOG END-------------

This is likely caused by send_shutdown use, introducing a race condition between the shutdown and the testcase execution.

tags: added: ci upstream

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2243

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers