Cannot start Percona Server using mysql.server due to calling mysqld_safe from absolute path

Bug #1670588 reported by Jaime Sicam on 2017-03-07
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
MySQL Server
Unknown
Unknown
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Medium
Unassigned
5.6
Fix Released
Medium
Unassigned
5.7
Fix Released
Medium
Unassigned

Bug Description

How to reproduce with MySQL sandbox:

1. Setup:
mkdir ~/binaries
cd ~/binaries
wget https://www.percona.com/downloads/Percona-Server-LATEST/Percona-Server-5.7.17-11/binary/tarball/Percona-Server-5.7.17-11-Linux.x86_64.ssl100.tar.gz
make_sandbox Percona-Server-5.7.17-11/binary/tarball/Percona-Server-5.7.17-11-Linux.x86_64.ssl100.tar.gz
sudo cp ~/sandboxes/msb_5_7_17/my.sandbox.cnf /etc/my.cnf

2. Testing:
cd ~/binaries/5.7.17/support-files
./mysql.server stop
Shutting down MySQL (Percona Server)
... *

./mysql.server start
Starting MySQL (Percona Server)
.2017-03-07T07:07:50.383608Z mysqld_safe The file /usr/local/Percona-Server-5.7.17-11-Linux.x86_64.ssl100/bin/mysqld
does not exist or is not executable. Please cd to the mysql installation
directory and restart this script from there as follows:
./bin/mysqld_safe&
See http://dev.mysql.com/doc/mysql/en/mysqld-safe.html for more information
 * The server quit without updating PID file (/home/user/sandboxes/msb_5_7_17/data/mysql_sandbox5717.pid).

3. To fix:
Edit mysql.server
Find:
$bindir/mysqld_safe --datadir="$datadir" --pid-file="$mysqld_pid_file_path" $other_args >/dev/null &
Change to:
bin/mysqld_safe --datadir="$datadir" --pid-file="$mysqld_pid_file_path" $other_args >/dev/null &

./mysql.server start
Starting MySQL (Percona Server)
.. *

Jaime Sicam (jssicam) on 2017-03-07
tags: added: i166448
removed: 166448
summary: - Cannot start Percona Server using mysql.server due to default file path
- for PS installation
+ Cannot start Percona Server using mysql.server due to calling
+ mysqld_safe from absolute path
Changed in percona-server:
status: New → Confirmed
Sveta Smirnova (svetasmirnova) wrote :

This is fixed in upstream version 5.7.18. See https://bugs.mysql.com/bug.php?id=84263 and https://bugs.mysql.com/bug.php?id=84173 for details

tags: added: regression upstream
Yura Sorokin (yura-sorokin) wrote :

5.5 fixed as part of the 5.5.55 upstream merge
https://github.com/percona/percona-server/pull/1651

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-1787

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.