Intermittent testcase check warning on innodb_stress.innodb_hugestress_blob

Bug #1660348 reported by Laurynas Biveinis on 2017-01-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Invalid
Undecided
Unassigned
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

On 5.6 trunk:

innodb_stress.innodb_hugestress_blob w4 [ pass ] 1548600

MTR's internal check of the test case 'innodb_stress.innodb_hugestress_blob' failed.
This means that the test case does not preserve the state that existed
before the test case was executed. Most likely the test case did not
do a proper clean-up. It could also be caused by the previous test run
by this thread, if the server wasn't restarted.
This is the diff of the states of the servers before and after the
test case was executed:
mysqltest: Logging to '/mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/release/Host/ubuntu-xenial-64bit/build/mysql-test/var/4/tmp/check-mysqld_1.log'.
mysqltest: Results saved in '/mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/release/Host/ubuntu-xenial-64bit/build/mysql-test/var/4/tmp/check-mysqld_1.result'.
mysqltest: Connecting to server localhost:13031 (socket /tmp/m_kFskIu1U/4/mysqld.1.sock) as 'root', connection 'default', attempt 0 ...
mysqltest: ... Connected.
mysqltest: Start processing test commands from './include/check-testcase.test' ...
mysqltest: ... Done processing test commands.
--- /mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/release/Host/ubuntu-xenial-64bit/build/mysql-test/var/4/tmp/check-mysqld_1.result 2017-01-28 16:26:01.771957710 +0300
+++ /mnt/workspace/percona-server-5.6-trunk/BUILD_TYPE/release/Host/ubuntu-xenial-64bit/build/mysql-test/var/4/tmp/check-mysqld_1.reject 2017-01-28 16:51:51.203777764 +0300
@@ -297,7 +297,7 @@
 INNODB_STATS_PERSISTENT_SAMPLE_PAGES 20
 INNODB_STATS_SAMPLE_PAGES 8
 INNODB_STATS_TRANSIENT_SAMPLE_PAGES 8
-INNODB_STATUS_OUTPUT OFF
+INNODB_STATUS_OUTPUT ON
 INNODB_STATUS_OUTPUT_LOCKS OFF
 INNODB_STRICT_MODE OFF
 INNODB_SUPPORT_XA ON

mysqltest: Result content mismatch

The testcase itself does not enable innodb_status_output variable nor creates the InnoDB monitor tables. But, it suppresses all the warnings indiscriminately, and it is possible that InnoDB enabled InnoDB monitor internally due to a long lock wait or similar.

tags: added: ci upstream

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2229

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers