Test rpl.rpl_semi_sync_event is unstable

Bug #1660243 reported by Laurynas Biveinis
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Percona Server moved to https://jira.percona.com/projects/PS
Status tracked in 5.7
5.5
Fix Released
Low
Laurynas Biveinis
5.6
Fix Released
Low
Laurynas Biveinis
5.7
Fix Released
Low
Laurynas Biveinis

Bug Description

On 5.6 trunk:

rpl.rpl_semi_sync_event 'mix' w4 [ fail ]
        Test ended at 2017-01-24 07:13:00

CURRENT_TEST: rpl.rpl_semi_sync_event
mysqltest: At line 101: query 'UNINSTALL PLUGIN rpl_semi_sync_master' failed: 1883: Plugin 'rpl_semi_sync_master' cannot be uninstalled now. Stop any active semisynchronous slaves of this master first.

This seems to have the same root cause as bug 1617150: a race condition between master server disconnecting the semisync slave asynchronously with the testcase attempting to uninstall the semisync rpl master plugin.

tags: added: ci upstream
Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :
Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :

Seen on 5.5 too

Revision history for this message
Laurynas Biveinis (laurynas-biveinis) wrote :
Revision history for this message
Shahriyar Rzayev (rzayev-sehriyar) wrote :

Percona now uses JIRA for bug reports so this bug report is migrated to: https://jira.percona.com/browse/PS-2228

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers